aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-07-19 14:33:14 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-06 13:38:55 +0000
commit82435af22634ce7fcd194ea56fc063a76bc66ec3 (patch)
treed1ea2756e3a7beb6bc12d76061fe5a7a842e5fed /CMakeLists.txt
parent108ba34909a12d5d2d02a8a9cb738aaf65ac8868 (diff)
Initial CMake conversion for QtQuickControls2
The CMake setup only covers everything under the src directory. Tests and examples will follow in separate patches. Change-Id: Ic4dbf6efa3128d0eea3af99117ba87690cb51077 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..e5ed902d
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 3.15.0)
+
+project(QtQuickControls2
+ VERSION 6.0.0
+ DESCRIPTION "Qt QuickControls2 Libraries"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network Qml Quick QmlTools)
+qt_build_repo()