aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-09-23 11:36:27 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-07 21:54:34 +0200
commite1d2073ddbd81e926640babe94e6d64076ce8eaa (patch)
tree2bc45e175bb4f1b174e28d8816dc0279a57f5066 /CMakeLists.txt
parented65d1ab49e6f5537b086178f9f9d14fc190b663 (diff)
CMake: Disable usage of CMake API compatibility wrappers
Setting the QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS variable in the project ensures we ported away from old API calls. Task-number: QTBUG-86815 Change-Id: I3ca1422448dbcadfdb3ed668ba4cfcddcb2d5b7e Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2c31a50f..d6dbb0d6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,11 @@ project(QtQuickControls2
LANGUAGES CXX C
)
+# special case begin
+# Make sure we only use latest private CMake API, aka no compatibility wrappers.
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+# special case end
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network Qml Quick # special case
OPTIONAL_COMPONENTS QuickTest # special case
)