aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 12:34:56 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-04-16 20:43:24 +0200
commit3d5254938c94e4f527d2e2aa2dd684b08cb15ded (patch)
treea4f8d95f7dc02dd9e09d2e86280a789f2095894a /src/imports/controls/CMakeLists.txt
parent7583387fda51f06ac3ee55ba21790b02824d6a5b (diff)
CMake: Fix qml module version to use the repo project version
Use PROJECT_VERSION instead of CMAKE_PROJECT_VERSION, so that the repo project version is used in a top-level build, rather than the version of the qt5 project. Task-number: QTBUG-92861 Change-Id: Ifd12d6309f358b9b72372a5c069141ecb7322bc7 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> (cherry picked from commit 22e3b6d2292ded526354569a1ffb342a660f1f80)
Diffstat (limited to 'src/imports/controls/CMakeLists.txt')
-rw-r--r--src/imports/controls/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/imports/controls/CMakeLists.txt b/src/imports/controls/CMakeLists.txt
index 637e267f..38454f99 100644
--- a/src/imports/controls/CMakeLists.txt
+++ b/src/imports/controls/CMakeLists.txt
@@ -6,7 +6,7 @@
qt_internal_add_qml_module(qtquickcontrols2plugin
URI "QtQuick.Controls"
- VERSION "6.0" # special case
+ VERSION "${PROJECT_VERSION}"
DESIGNER_SUPPORTED
CLASSNAME QtQuickControls2Plugin
SKIP_TYPE_REGISTRATION