aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/fusion
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-09-24 13:25:15 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-10-08 14:17:14 +0000
commit2d4f2f1f4a4ff2f6e6189d9206875927d529f4c2 (patch)
tree2de4d49455544b28ff43fd95d4690474521111fb /src/imports/controls/fusion
parentfa53bd50f15b5b213ed205ccc0a6f5dd21471222 (diff)
Update QtQuickControls2 project files
Re-run pro2cmake on all the project files. Change-Id: I8d349cf34d6cc8e26c76193d9ef220fa85b16bb8 Reviewed-by: Qt CMake Build Bot Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/imports/controls/fusion')
-rw-r--r--src/imports/controls/fusion/.prev_CMakeLists.txt132
-rw-r--r--src/imports/controls/fusion/CMakeLists.txt161
2 files changed, 214 insertions, 79 deletions
diff --git a/src/imports/controls/fusion/.prev_CMakeLists.txt b/src/imports/controls/fusion/.prev_CMakeLists.txt
new file mode 100644
index 00000000..f2b3cd5e
--- /dev/null
+++ b/src/imports/controls/fusion/.prev_CMakeLists.txt
@@ -0,0 +1,132 @@
+# Generated from fusion.pro.
+
+#####################################################################
+## qtquickcontrols2fusionstyleplugin Plugin:
+#####################################################################
+
+add_qml_module(qtquickcontrols2fusionstyleplugin
+ TARGET_PATH "QtQuick/Controls.2/Fusion"
+ URI "QtQuick.Controls.Fusion"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQuickControls2FusionStylePlugin
+ DEPENDENCIES
+ QtQuick.Controls/2.5
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ qquickfusionbusyindicator.cpp qquickfusionbusyindicator_p.h
+ qquickfusiondial.cpp qquickfusiondial_p.h
+ qquickfusionknob.cpp qquickfusionknob_p.h
+ qquickfusionstyle.cpp qquickfusionstyle_p.h
+ qquickfusiontheme.cpp qquickfusiontheme_p.h
+ qtquickcontrols2fusionstyleplugin.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickControls2Private
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(qtquickcontrols2fusionstyle_resource_files
+ "images/arrow.png"
+ "images/arrow@2x.png"
+ "images/arrow@3x.png"
+ "images/arrow@4x.png"
+ "images/checkmark.png"
+ "images/checkmark@2x.png"
+ "images/checkmark@3x.png"
+ "images/checkmark@4x.png"
+ "images/progressmask.png"
+ "images/progressmask@2x.png"
+ "images/progressmask@3x.png"
+ "images/progressmask@4x.png"
+)
+
+add_qt_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
+ PREFIX
+ "/qt-project.org/imports/QtQuick/Controls.2/Fusion"
+ FILES
+ ${qtquickcontrols2fusionstyle_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:fusion.pro:<TRUE>:
+# IMPORT_NAME = "QtQuick.Controls.Fusion"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# OTHER_FILES = "qmldir" "$$QML_FILES"
+# TARGETPATH = "QtQuick/Controls.2/Fusion"
+# _LOADED = "qml_plugin"
+
+set(qml_files
+ "ApplicationWindow.qml"
+ "BusyIndicator.qml"
+ "Button.qml"
+ "ButtonPanel.qml"
+ "CheckBox.qml"
+ "CheckDelegate.qml"
+ "CheckIndicator.qml"
+ "ComboBox.qml"
+ "DelayButton.qml"
+ "Dial.qml"
+ "Dialog.qml"
+ "DialogButtonBox.qml"
+ "Drawer.qml"
+ "Frame.qml"
+ "GroupBox.qml"
+ "ItemDelegate.qml"
+ "Label.qml"
+ "Menu.qml"
+ "MenuBar.qml"
+ "MenuBarItem.qml"
+ "MenuItem.qml"
+ "MenuSeparator.qml"
+ "Page.qml"
+ "PageIndicator.qml"
+ "Pane.qml"
+ "Popup.qml"
+ "ProgressBar.qml"
+ "RadioButton.qml"
+ "RadioDelegate.qml"
+ "RadioIndicator.qml"
+ "RangeSlider.qml"
+ "RoundButton.qml"
+ "ScrollBar.qml"
+ "ScrollIndicator.qml"
+ "Slider.qml"
+ "SliderGroove.qml"
+ "SliderHandle.qml"
+ "SpinBox.qml"
+ "SplitView.qml"
+ "SwipeDelegate.qml"
+ "SwitchDelegate.qml"
+ "SwitchIndicator.qml"
+ "Switch.qml"
+ "TabBar.qml"
+ "TabButton.qml"
+ "TextArea.qml"
+ "TextField.qml"
+ "ToolBar.qml"
+ "ToolButton.qml"
+ "ToolSeparator.qml"
+ "ToolTip.qml"
+ "Tumbler.qml"
+)
+
+set_source_files_properties(${qml_files} PROPERTIES
+ QT_QML_SOURCE_INSTALL TRUE
+)
+
+qt6_target_qml_files(qtquickcontrols2fusionstyleplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/controls/fusion/CMakeLists.txt b/src/imports/controls/fusion/CMakeLists.txt
index 3607f27c..581dc739 100644
--- a/src/imports/controls/fusion/CMakeLists.txt
+++ b/src/imports/controls/fusion/CMakeLists.txt
@@ -5,10 +5,13 @@
#####################################################################
add_qml_module(qtquickcontrols2fusionstyleplugin
- CPP_PLUGIN
TARGET_PATH "QtQuick/Controls.2/Fusion"
URI "QtQuick.Controls.Fusion"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQuickControls2FusionStylePlugin
+ DEPENDENCIES
+ QtQuick.Controls/2.5
+ SKIP_TYPE_REGISTRATION
SOURCES
qquickfusionbusyindicator.cpp qquickfusionbusyindicator_p.h
qquickfusiondial.cpp qquickfusiondial_p.h
@@ -34,93 +37,93 @@ add_qml_module(qtquickcontrols2fusionstyleplugin
)
# Resources:
+set(qtquickcontrols2fusionstyle_resource_files
+ "images/arrow.png"
+ "images/arrow@2x.png"
+ "images/arrow@3x.png"
+ "images/arrow@4x.png"
+ "images/checkmark.png"
+ "images/checkmark@2x.png"
+ "images/checkmark@3x.png"
+ "images/checkmark@4x.png"
+ "images/progressmask.png"
+ "images/progressmask@2x.png"
+ "images/progressmask@3x.png"
+ "images/progressmask@4x.png"
+)
+
add_qt_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
PREFIX
- "qt-project.org/imports/QtQuick/Controls.2/Fusion"
+ "/qt-project.org/imports/QtQuick/Controls.2/Fusion"
FILES
- images/arrow.png
- images/arrow@2x.png
- images/arrow@3x.png
- images/arrow@4x.png
- images/checkmark.png
- images/checkmark@2x.png
- images/checkmark@3x.png
- images/checkmark@4x.png
- images/progressmask.png
- images/progressmask@2x.png
- images/progressmask@3x.png
- images/progressmask@4x.png
+ ${qtquickcontrols2fusionstyle_resource_files}
)
+#### Keys ignored in scope 1:.:.:fusion.pro:<TRUE>:
+# IMPORT_NAME = "QtQuick.Controls.Fusion"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# OTHER_FILES = "qmldir" "$$QML_FILES"
+# TARGETPATH = "QtQuick/Controls.2/Fusion"
+# _LOADED = "qml_plugin"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-fusion)"
+
set(qml_files
- ApplicationWindow.qml
- BusyIndicator.qml
- Button.qml
- ButtonPanel.qml
- CheckBox.qml
- CheckDelegate.qml
- CheckIndicator.qml
- ComboBox.qml
- DelayButton.qml
- Dial.qml
- Dialog.qml
- DialogButtonBox.qml
- Drawer.qml
- Frame.qml
- GroupBox.qml
- ItemDelegate.qml
- Label.qml
- Menu.qml
- MenuBar.qml
- MenuBarItem.qml
- MenuItem.qml
- MenuSeparator.qml
- Page.qml
- PageIndicator.qml
- Pane.qml
- Popup.qml
- ProgressBar.qml
- RadioButton.qml
- RadioDelegate.qml
- RadioIndicator.qml
- RangeSlider.qml
- RoundButton.qml
- ScrollBar.qml
- ScrollIndicator.qml
- Slider.qml
- SliderGroove.qml
- SliderHandle.qml
- SpinBox.qml
- SplitView.qml
- SwipeDelegate.qml
- SwitchDelegate.qml
- SwitchIndicator.qml
- Switch.qml
- TabBar.qml
- TabButton.qml
- TextArea.qml
- TextField.qml
- ToolBar.qml
- ToolButton.qml
- ToolSeparator.qml
- ToolTip.qml
- Tumbler.qml
+ "ApplicationWindow.qml"
+ "BusyIndicator.qml"
+ "Button.qml"
+ "ButtonPanel.qml"
+ "CheckBox.qml"
+ "CheckDelegate.qml"
+ "CheckIndicator.qml"
+ "ComboBox.qml"
+ "DelayButton.qml"
+ "Dial.qml"
+ "Dialog.qml"
+ "DialogButtonBox.qml"
+ "Drawer.qml"
+ "Frame.qml"
+ "GroupBox.qml"
+ "ItemDelegate.qml"
+ "Label.qml"
+ "Menu.qml"
+ "MenuBar.qml"
+ "MenuBarItem.qml"
+ "MenuItem.qml"
+ "MenuSeparator.qml"
+ "Page.qml"
+ "PageIndicator.qml"
+ "Pane.qml"
+ "Popup.qml"
+ "ProgressBar.qml"
+ "RadioButton.qml"
+ "RadioDelegate.qml"
+ "RadioIndicator.qml"
+ "RangeSlider.qml"
+ "RoundButton.qml"
+ "ScrollBar.qml"
+ "ScrollIndicator.qml"
+ "Slider.qml"
+ "SliderGroove.qml"
+ "SliderHandle.qml"
+ "SpinBox.qml"
+ "SplitView.qml"
+ "SwipeDelegate.qml"
+ "SwitchDelegate.qml"
+ "SwitchIndicator.qml"
+ "Switch.qml"
+ "TabBar.qml"
+ "TabButton.qml"
+ "TextArea.qml"
+ "TextField.qml"
+ "ToolBar.qml"
+ "ToolButton.qml"
+ "ToolSeparator.qml"
+ "ToolTip.qml"
+ "Tumbler.qml"
)
-add_qt_resource(qtquickcontrols2fusionstyleplugin qmake_QtQuick_Controls_2_Fusion
+qt6_target_qml_files(qtquickcontrols2fusionstyleplugin
FILES
${qml_files}
)
-
-qt_install_qml_files(qtquickcontrols2fusionstyleplugin
- FILES ${qml_files}
-)
-
-
-#### Keys ignored in scope 1:.:.:fusion.pro:<TRUE>:
-# CONFIG = "no_cxx_module" "install_qml_files" "builtin_resources" "qtquickcompiler"
-# IMPORT_NAME = "QtQuick.Controls.Fusion"
-# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
-# OTHER_FILES = "qmldir" "$$QML_FILES"
-# _LOADED = "qml_plugin"