aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/imagine
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-09-24 13:25:15 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-10-08 14:17:14 +0000
commit2d4f2f1f4a4ff2f6e6189d9206875927d529f4c2 (patch)
tree2de4d49455544b28ff43fd95d4690474521111fb /src/imports/controls/imagine
parentfa53bd50f15b5b213ed205ccc0a6f5dd21471222 (diff)
Update QtQuickControls2 project files
Re-run pro2cmake on all the project files. Change-Id: I8d349cf34d6cc8e26c76193d9ef220fa85b16bb8 Reviewed-by: Qt CMake Build Bot Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/imports/controls/imagine')
-rw-r--r--src/imports/controls/imagine/.prev_CMakeLists.txt126
-rw-r--r--src/imports/controls/imagine/CMakeLists.txt136
2 files changed, 205 insertions, 57 deletions
diff --git a/src/imports/controls/imagine/.prev_CMakeLists.txt b/src/imports/controls/imagine/.prev_CMakeLists.txt
new file mode 100644
index 00000000..b2a50e05
--- /dev/null
+++ b/src/imports/controls/imagine/.prev_CMakeLists.txt
@@ -0,0 +1,126 @@
+# Generated from imagine.pro.
+
+#####################################################################
+## qtquickcontrols2imaginestyleplugin Plugin:
+#####################################################################
+
+add_qml_module(qtquickcontrols2imaginestyleplugin
+ TARGET_PATH "QtQuick/Controls.2/Imagine"
+ URI "QtQuick.Controls.Imagine"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQuickControls2ImagineStylePlugin
+ DEPENDENCIES
+ QtQuick.Controls/2.5
+ QtGraphicalEffects/1.0
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ qquickimageselector.cpp qquickimageselector_p.h
+ qquickimaginestyle.cpp qquickimaginestyle_p.h
+ qquickimaginetheme.cpp qquickimaginetheme_p.h
+ qquickninepatchimage.cpp qquickninepatchimage_p.h
+ qtquickcontrols2imaginestyleplugin.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickControls2Private
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+file(GLOB resource_glob_0 RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "images/*.png")
+foreach(file IN LISTS resource_glob_0)
+ set_source_files_properties("${CMAKE_CURRENT_SOURCE_DIR}/${file}" PROPERTIES QT_RESOURCE_ALIAS "${file}")
+endforeach()
+
+file(GLOB resource_glob_1 RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "images/*.webp")
+foreach(file IN LISTS resource_glob_1)
+ set_source_files_properties("${CMAKE_CURRENT_SOURCE_DIR}/${file}" PROPERTIES QT_RESOURCE_ALIAS "${file}")
+endforeach()
+
+# Resources:
+set(qmake_qtquickcontrols2imaginestyle_resource_files
+ ${resource_glob_0}
+ ${resource_glob_1}
+)
+
+add_qt_resource(qtquickcontrols2imaginestyleplugin "qmake_qtquickcontrols2imaginestyle"
+ PREFIX
+ "qt-project.org/imports/QtQuick/Controls.2/Imagine"
+ FILES
+ ${qmake_qtquickcontrols2imaginestyle_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:imagine.pro:<TRUE>:
+# IMPORT_NAME = "QtQuick.Controls.Imagine"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# OTHER_FILES = "qmldir" "$$QML_FILES"
+# TARGETPATH = "QtQuick/Controls.2/Imagine"
+# _LOADED = "qml_plugin"
+
+set(qml_files
+ "ApplicationWindow.qml"
+ "BusyIndicator.qml"
+ "Button.qml"
+ "CheckBox.qml"
+ "CheckDelegate.qml"
+ "ComboBox.qml"
+ "DelayButton.qml"
+ "Dial.qml"
+ "Dialog.qml"
+ "DialogButtonBox.qml"
+ "Drawer.qml"
+ "Frame.qml"
+ "GroupBox.qml"
+ "ItemDelegate.qml"
+ "Label.qml"
+ "Menu.qml"
+ "MenuItem.qml"
+ "MenuSeparator.qml"
+ "PageIndicator.qml"
+ "Page.qml"
+ "Pane.qml"
+ "Popup.qml"
+ "ProgressBar.qml"
+ "RadioButton.qml"
+ "RadioDelegate.qml"
+ "RangeSlider.qml"
+ "RoundButton.qml"
+ "ScrollBar.qml"
+ "ScrollIndicator.qml"
+ "Slider.qml"
+ "SpinBox.qml"
+ "SplitView.qml"
+ "StackView.qml"
+ "SwipeDelegate.qml"
+ "SwipeView.qml"
+ "Switch.qml"
+ "SwitchDelegate.qml"
+ "TextField.qml"
+ "TextArea.qml"
+ "TabBar.qml"
+ "TabButton.qml"
+ "ToolBar.qml"
+ "ToolButton.qml"
+ "ToolSeparator.qml"
+ "ToolTip.qml"
+ "Tumbler.qml"
+)
+
+set_source_files_properties(${qml_files} PROPERTIES
+ QT_QML_SOURCE_INSTALL TRUE
+)
+
+qt6_target_qml_files(qtquickcontrols2imaginestyleplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/controls/imagine/CMakeLists.txt b/src/imports/controls/imagine/CMakeLists.txt
index bc89f88a..98661788 100644
--- a/src/imports/controls/imagine/CMakeLists.txt
+++ b/src/imports/controls/imagine/CMakeLists.txt
@@ -5,10 +5,14 @@
#####################################################################
add_qml_module(qtquickcontrols2imaginestyleplugin
- CPP_PLUGIN
TARGET_PATH "QtQuick/Controls.2/Imagine"
URI "QtQuick.Controls.Imagine"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQuickControls2ImagineStylePlugin
+ DEPENDENCIES
+ QtQuick.Controls/2.5
+ QtGraphicalEffects/1.0
+ SKIP_TYPE_REGISTRATION
SOURCES
qquickimageselector.cpp qquickimageselector_p.h
qquickimaginestyle.cpp qquickimaginestyle_p.h
@@ -32,70 +36,88 @@ add_qml_module(qtquickcontrols2imaginestyleplugin
Qt::Quick
)
-set(qml_files
- ApplicationWindow.qml
- BusyIndicator.qml
- Button.qml
- CheckBox.qml
- CheckDelegate.qml
- ComboBox.qml
- DelayButton.qml
- Dial.qml
- Dialog.qml
- DialogButtonBox.qml
- Drawer.qml
- Frame.qml
- GroupBox.qml
- ItemDelegate.qml
- Label.qml
- Menu.qml
- MenuItem.qml
- MenuSeparator.qml
- PageIndicator.qml
- Page.qml
- Pane.qml
- Popup.qml
- ProgressBar.qml
- RadioButton.qml
- RadioDelegate.qml
- RangeSlider.qml
- RoundButton.qml
- ScrollBar.qml
- ScrollIndicator.qml
- Slider.qml
- SpinBox.qml
- SplitView.qml
- StackView.qml
- SwipeDelegate.qml
- SwipeView.qml
- Switch.qml
- SwitchDelegate.qml
- TextField.qml
- TextArea.qml
- TabBar.qml
- TabButton.qml
- ToolBar.qml
- ToolButton.qml
- ToolSeparator.qml
- ToolTip.qml
- Tumbler.qml
-)
+file(GLOB resource_glob_0 RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "images/*.png")
+foreach(file IN LISTS resource_glob_0)
+ set_source_files_properties("${CMAKE_CURRENT_SOURCE_DIR}/${file}" PROPERTIES QT_RESOURCE_ALIAS "${file}")
+endforeach()
-add_qt_resource(qtquickcontrols2imaginestyleplugin qmake_QtQuick_Controls_2_Imagine
- FILES
- ${qml_files}
+file(GLOB resource_glob_1 RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "images/*.webp")
+foreach(file IN LISTS resource_glob_1)
+ set_source_files_properties("${CMAKE_CURRENT_SOURCE_DIR}/${file}" PROPERTIES QT_RESOURCE_ALIAS "${file}")
+endforeach()
+
+# Resources:
+set(qmake_qtquickcontrols2imaginestyle_resource_files
+ ${resource_glob_0}
+ ${resource_glob_1}
)
-qt_install_qml_files(qtquickcontrols2imaginestyleplugin
- FILES ${qml_files}
+add_qt_resource(qtquickcontrols2imaginestyleplugin "qmake_qtquickcontrols2imaginestyle"
+ PREFIX
+ "qt-project.org/imports/QtQuick/Controls.2/Imagine"
+ FILES
+ ${qmake_qtquickcontrols2imaginestyle_resource_files}
)
#### Keys ignored in scope 1:.:.:imagine.pro:<TRUE>:
-# CONFIG = "no_cxx_module" "install_qml_files" "builtin_resources" "qtquickcompiler"
# IMPORT_NAME = "QtQuick.Controls.Imagine"
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
+# TARGETPATH = "QtQuick/Controls.2/Imagine"
# _LOADED = "qml_plugin"
-# qtquickcontrols2imaginestyle.files = "$$files$$PWD/images/*.png" "$$files$$PWD/images/*.webp"
-# qtquickcontrols2imaginestyle.prefix = "qt-project.org/imports/QtQuick/Controls.2/Imagine"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-imagine)"
+
+set(qml_files
+ "ApplicationWindow.qml"
+ "BusyIndicator.qml"
+ "Button.qml"
+ "CheckBox.qml"
+ "CheckDelegate.qml"
+ "ComboBox.qml"
+ "DelayButton.qml"
+ "Dial.qml"
+ "Dialog.qml"
+ "DialogButtonBox.qml"
+ "Drawer.qml"
+ "Frame.qml"
+ "GroupBox.qml"
+ "ItemDelegate.qml"
+ "Label.qml"
+ "Menu.qml"
+ "MenuItem.qml"
+ "MenuSeparator.qml"
+ "PageIndicator.qml"
+ "Page.qml"
+ "Pane.qml"
+ "Popup.qml"
+ "ProgressBar.qml"
+ "RadioButton.qml"
+ "RadioDelegate.qml"
+ "RangeSlider.qml"
+ "RoundButton.qml"
+ "ScrollBar.qml"
+ "ScrollIndicator.qml"
+ "Slider.qml"
+ "SpinBox.qml"
+ "SplitView.qml"
+ "StackView.qml"
+ "SwipeDelegate.qml"
+ "SwipeView.qml"
+ "Switch.qml"
+ "SwitchDelegate.qml"
+ "TextField.qml"
+ "TextArea.qml"
+ "TabBar.qml"
+ "TabButton.qml"
+ "ToolBar.qml"
+ "ToolButton.qml"
+ "ToolSeparator.qml"
+ "ToolTip.qml"
+ "Tumbler.qml"
+)
+
+qt6_target_qml_files(qtquickcontrols2imaginestyleplugin
+ FILES
+ ${qml_files}
+)