aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/macos/.prev_CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-09-23 11:34:07 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-07 21:54:30 +0200
commited65d1ab49e6f5537b086178f9f9d14fc190b663 (patch)
treedca778ac347fb25b11bd665e0818f8454c7be0b1 /src/imports/controls/macos/.prev_CMakeLists.txt
parent81e8cd67198768a08f5c65ec026e1553f78e1375 (diff)
CMake: Regenerate projects to use new qt_internal_ API
Modify special case locations to use the new API as well. Task-number: QTBUG-86815 Change-Id: I4a690095fcd4b1141550de86b6820ae2dd579429 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'src/imports/controls/macos/.prev_CMakeLists.txt')
-rw-r--r--src/imports/controls/macos/.prev_CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/imports/controls/macos/.prev_CMakeLists.txt b/src/imports/controls/macos/.prev_CMakeLists.txt
index a8fca854..53584ac4 100644
--- a/src/imports/controls/macos/.prev_CMakeLists.txt
+++ b/src/imports/controls/macos/.prev_CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2macosstyleplugin Plugin:
#####################################################################
-qt_add_qml_module(qtquickcontrols2macosstyleplugin
+qt_internal_add_qml_module(qtquickcontrols2macosstyleplugin
URI "QtQuick.Controls.macOS"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickControls2MacOSStylePlugin
@@ -50,6 +50,7 @@ set(qml_files
"Frame.qml"
"TextArea.qml"
"ComboBox.qml"
+ "ScrollView.qml"
"ScrollBar.qml"
"ProgressBar.qml"
"Dial.qml"
@@ -84,6 +85,9 @@ set_source_files_properties(TextArea.qml PROPERTIES
set_source_files_properties(ComboBox.qml PROPERTIES
QT_QML_SOURCE_VERSION "6.0"
)
+set_source_files_properties(ScrollView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
set_source_files_properties(ScrollBar.qml PROPERTIES
QT_QML_SOURCE_VERSION "6.0"
)