aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/material
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-09-24 13:25:15 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-10-08 14:17:14 +0000
commit2d4f2f1f4a4ff2f6e6189d9206875927d529f4c2 (patch)
tree2de4d49455544b28ff43fd95d4690474521111fb /src/imports/controls/material
parentfa53bd50f15b5b213ed205ccc0a6f5dd21471222 (diff)
Update QtQuickControls2 project files
Re-run pro2cmake on all the project files. Change-Id: I8d349cf34d6cc8e26c76193d9ef220fa85b16bb8 Reviewed-by: Qt CMake Build Bot Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/imports/controls/material')
-rw-r--r--src/imports/controls/material/.prev_CMakeLists.txt140
-rw-r--r--src/imports/controls/material/CMakeLists.txt26
2 files changed, 153 insertions, 13 deletions
diff --git a/src/imports/controls/material/.prev_CMakeLists.txt b/src/imports/controls/material/.prev_CMakeLists.txt
new file mode 100644
index 00000000..3cf6d5d2
--- /dev/null
+++ b/src/imports/controls/material/.prev_CMakeLists.txt
@@ -0,0 +1,140 @@
+# Generated from material.pro.
+
+#####################################################################
+## qtquickcontrols2materialstyleplugin Plugin:
+#####################################################################
+
+add_qml_module(qtquickcontrols2materialstyleplugin
+ TARGET_PATH "QtQuick/Controls.2/Material"
+ URI "QtQuick.Controls.Material"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQuickControls2MaterialStylePlugin
+ DEPENDENCIES
+ QtQuick.Controls/2.5
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ qquickmaterialbusyindicator.cpp qquickmaterialbusyindicator_p.h
+ qquickmaterialprogressbar.cpp qquickmaterialprogressbar_p.h
+ qquickmaterialripple.cpp qquickmaterialripple_p.h
+ qquickmaterialstyle.cpp qquickmaterialstyle_p.h
+ qquickmaterialtheme.cpp qquickmaterialtheme_p.h
+ qtquickcontrols2materialstyleplugin.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickControls2Private
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(qtquickcontrols2materialstyleplugin_resource_files
+ "images/arrow-indicator.png"
+ "images/arrow-indicator@2x.png"
+ "images/arrow-indicator@3x.png"
+ "images/arrow-indicator@4x.png"
+ "images/check.png"
+ "images/check@2x.png"
+ "images/check@3x.png"
+ "images/check@4x.png"
+ "images/drop-indicator.png"
+ "images/drop-indicator@2x.png"
+ "images/drop-indicator@3x.png"
+ "images/drop-indicator@4x.png"
+ "shaders/+glslcore/RectangularGlow.frag"
+ "shaders/+hlsl/RectangularGlow.frag"
+ "shaders/+qsb/RectangularGlow.frag"
+ "shaders/RectangularGlow.frag"
+)
+
+add_qt_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialstyleplugin"
+ PREFIX
+ "/qt-project.org/imports/QtQuick/Controls.2/Material"
+ FILES
+ ${qtquickcontrols2materialstyleplugin_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:material.pro:<TRUE>:
+# IMPORT_NAME = "QtQuick.Controls.Material"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# OTHER_FILES = "qmldir" "$$QML_FILES"
+# TARGETPATH = "QtQuick/Controls.2/Material"
+# _LOADED = "qml_plugin"
+
+set(qml_files
+ "ApplicationWindow.qml"
+ "BoxShadow.qml"
+ "BusyIndicator.qml"
+ "Button.qml"
+ "CheckBox.qml"
+ "CheckDelegate.qml"
+ "CheckIndicator.qml"
+ "ComboBox.qml"
+ "CursorDelegate.qml"
+ "DelayButton.qml"
+ "Dial.qml"
+ "Dialog.qml"
+ "DialogButtonBox.qml"
+ "Drawer.qml"
+ "ElevationEffect.qml"
+ "Frame.qml"
+ "GroupBox.qml"
+ "ItemDelegate.qml"
+ "Label.qml"
+ "Menu.qml"
+ "MenuBar.qml"
+ "MenuBarItem.qml"
+ "MenuItem.qml"
+ "MenuSeparator.qml"
+ "Page.qml"
+ "PageIndicator.qml"
+ "Pane.qml"
+ "Popup.qml"
+ "ProgressBar.qml"
+ "RadioButton.qml"
+ "RadioDelegate.qml"
+ "RadioIndicator.qml"
+ "RangeSlider.qml"
+ "RoundButton.qml"
+ "RectangularGlow.qml"
+ "ScrollBar.qml"
+ "ScrollIndicator.qml"
+ "Slider.qml"
+ "SliderHandle.qml"
+ "SpinBox.qml"
+ "SplitView.qml"
+ "StackView.qml"
+ "SwipeDelegate.qml"
+ "SwipeView.qml"
+ "Switch.qml"
+ "SwitchDelegate.qml"
+ "SwitchIndicator.qml"
+ "TabBar.qml"
+ "TabButton.qml"
+ "TextArea.qml"
+ "TextField.qml"
+ "ToolBar.qml"
+ "ToolButton.qml"
+ "ToolSeparator.qml"
+ "ToolTip.qml"
+ "Tumbler.qml"
+)
+
+set_source_files_properties(${qml_files} PROPERTIES
+ QT_QML_SOURCE_INSTALL TRUE
+)
+
+qt6_target_qml_files(qtquickcontrols2materialstyleplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/controls/material/CMakeLists.txt b/src/imports/controls/material/CMakeLists.txt
index c1c964b2..ae5ffe83 100644
--- a/src/imports/controls/material/CMakeLists.txt
+++ b/src/imports/controls/material/CMakeLists.txt
@@ -5,10 +5,13 @@
#####################################################################
add_qml_module(qtquickcontrols2materialstyleplugin
- CPP_PLUGIN
TARGET_PATH "QtQuick/Controls.2/Material"
URI "QtQuick.Controls.Material"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQuickControls2MaterialStylePlugin
+ DEPENDENCIES
+ QtQuick.Controls/2.5
+ SKIP_TYPE_REGISTRATION
SOURCES
qquickmaterialbusyindicator.cpp qquickmaterialbusyindicator_p.h
qquickmaterialprogressbar.cpp qquickmaterialprogressbar_p.h
@@ -61,6 +64,14 @@ add_qt_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialsty
)
+#### Keys ignored in scope 1:.:.:material.pro:<TRUE>:
+# IMPORT_NAME = "QtQuick.Controls.Material"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# OTHER_FILES = "qmldir" "$$QML_FILES"
+# TARGETPATH = "QtQuick/Controls.2/Material"
+# _LOADED = "qml_plugin"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-material)"
+
set(qml_files
"ApplicationWindow.qml"
"BoxShadow.qml"
@@ -120,18 +131,7 @@ set(qml_files
"Tumbler.qml"
)
-add_qt_resource(qtquickcontrols2materialstyleplugin qmake_QtQuick_Controls_2_Material
+qt6_target_qml_files(qtquickcontrols2materialstyleplugin
FILES
${qml_files}
)
-
-qt_install_qml_files(qtquickcontrols2materialstyleplugin
- FILES ${qml_files}
-)
-
-
-#### Keys ignored in scope 1:.:.:material.pro:<TRUE>:
-# IMPORT_NAME = "QtQuick.Controls.Material"
-# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
-# OTHER_FILES = "qmldir" "$$QML_FILES"
-# _LOADED = "qml_plugin"