aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/material
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-09-23 11:34:07 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-07 21:54:30 +0200
commited65d1ab49e6f5537b086178f9f9d14fc190b663 (patch)
treedca778ac347fb25b11bd665e0818f8454c7be0b1 /src/imports/controls/material
parent81e8cd67198768a08f5c65ec026e1553f78e1375 (diff)
CMake: Regenerate projects to use new qt_internal_ API
Modify special case locations to use the new API as well. Task-number: QTBUG-86815 Change-Id: I4a690095fcd4b1141550de86b6820ae2dd579429 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'src/imports/controls/material')
-rw-r--r--src/imports/controls/material/.prev_CMakeLists.txt8
-rw-r--r--src/imports/controls/material/CMakeLists.txt7
-rw-r--r--src/imports/controls/material/impl/CMakeLists.txt2
3 files changed, 12 insertions, 5 deletions
diff --git a/src/imports/controls/material/.prev_CMakeLists.txt b/src/imports/controls/material/.prev_CMakeLists.txt
index 3f82f1e4..2547a0f8 100644
--- a/src/imports/controls/material/.prev_CMakeLists.txt
+++ b/src/imports/controls/material/.prev_CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2materialstyleplugin Plugin:
#####################################################################
-qt_add_qml_module(qtquickcontrols2materialstyleplugin
+qt_internal_add_qml_module(qtquickcontrols2materialstyleplugin
URI "QtQuick.Controls.Material"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickControls2MaterialStylePlugin
@@ -53,7 +53,7 @@ set(qtquickcontrols2materialstyleplugin_resource_files
"shaders/RectangularGlow.frag"
)
-qt_add_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialstyleplugin"
+qt_internal_add_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialstyleplugin"
PREFIX
"/qt-project.org/imports/QtQuick/Controls/Material"
FILES
@@ -99,6 +99,7 @@ set(qml_files
"RadioDelegate.qml"
"RangeSlider.qml"
"RoundButton.qml"
+ "ScrollView.qml"
"ScrollBar.qml"
"ScrollIndicator.qml"
"Slider.qml"
@@ -210,6 +211,9 @@ set_source_files_properties(RangeSlider.qml PROPERTIES
set_source_files_properties(RoundButton.qml PROPERTIES
QT_QML_SOURCE_VERSION "2.1;6.0"
)
+set_source_files_properties(ScrollView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
set_source_files_properties(ScrollBar.qml PROPERTIES
QT_QML_SOURCE_VERSION "2.0;6.0"
)
diff --git a/src/imports/controls/material/CMakeLists.txt b/src/imports/controls/material/CMakeLists.txt
index 9b70b6b5..7ba455e7 100644
--- a/src/imports/controls/material/CMakeLists.txt
+++ b/src/imports/controls/material/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2materialstyleplugin Plugin:
#####################################################################
-qt_add_qml_module(qtquickcontrols2materialstyleplugin
+qt_internal_add_qml_module(qtquickcontrols2materialstyleplugin
URI "QtQuick.Controls.Material"
VERSION "6.0" # special case
CLASSNAME QtQuickControls2MaterialStylePlugin
@@ -53,7 +53,7 @@ set(qtquickcontrols2materialstyleplugin_resource_files
"shaders/RectangularGlow.frag"
)
-qt_add_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialstyleplugin"
+qt_internal_add_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialstyleplugin"
PREFIX
"/qt-project.org/imports/QtQuick/Controls/Material"
FILES
@@ -211,6 +211,9 @@ set_source_files_properties(RangeSlider.qml PROPERTIES
set_source_files_properties(RoundButton.qml PROPERTIES
QT_QML_SOURCE_VERSION "2.1;6.0"
)
+set_source_files_properties(ScrollView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
set_source_files_properties(ScrollBar.qml PROPERTIES
QT_QML_SOURCE_VERSION "2.0;6.0"
)
diff --git a/src/imports/controls/material/impl/CMakeLists.txt b/src/imports/controls/material/impl/CMakeLists.txt
index bcb4f998..1f47650c 100644
--- a/src/imports/controls/material/impl/CMakeLists.txt
+++ b/src/imports/controls/material/impl/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2materialstyleimplplugin Plugin:
#####################################################################
-qt_add_qml_module(qtquickcontrols2materialstyleimplplugin
+qt_internal_add_qml_module(qtquickcontrols2materialstyleimplplugin
URI "QtQuick.Controls.Material.impl"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickControls2MaterialStyleImplPlugin