aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls
diff options
context:
space:
mode:
authorJan Arve Sæther <jan-arve.saether@qt.io>2020-10-13 16:02:47 +0200
committerJan Arve Sæther <jan-arve.saether@qt.io>2020-10-23 13:41:41 +0200
commit9a15b53e1ddf07807ca03cce7cd4321f4f11911d (patch)
treede7c26df2d091418fe9cbc0c666cb2877e8751cf /src/imports/controls
parenta83143078c96b421e684e508d02c6d3f024cc505 (diff)
Native style: Add ScrollBar on Windows
Change-Id: I82c8cf3e637550cd458ac77f2cc4f6490dc11802 Reviewed-by: Richard Moe Gustavsen <richard.gustavsen@qt.io>
Diffstat (limited to 'src/imports/controls')
-rw-r--r--src/imports/controls/windows/CMakeLists.txt1
-rw-r--r--src/imports/controls/windows/ScrollBar.qml84
-rw-r--r--src/imports/controls/windows/qmldir1
-rw-r--r--src/imports/controls/windows/windows.pri1
4 files changed, 87 insertions, 0 deletions
diff --git a/src/imports/controls/windows/CMakeLists.txt b/src/imports/controls/windows/CMakeLists.txt
index f1d01946..edd144bb 100644
--- a/src/imports/controls/windows/CMakeLists.txt
+++ b/src/imports/controls/windows/CMakeLists.txt
@@ -51,6 +51,7 @@ set(qml_files
"SpinBox.qml"
"TextArea.qml"
"TextField.qml"
+ "ScrollBar.qml"
"ScrollView.qml"
)
set_source_files_properties(Button.qml PROPERTIES
diff --git a/src/imports/controls/windows/ScrollBar.qml b/src/imports/controls/windows/ScrollBar.qml
new file mode 100644
index 00000000..d3b09418
--- /dev/null
+++ b/src/imports/controls/windows/ScrollBar.qml
@@ -0,0 +1,84 @@
+/****************************************************************************
+**
+** Copyright (C) 2020 The Qt Company Ltd.
+** Contact: http://www.qt.io/licensing/
+**
+** This file is part of the Qt Quick Controls 2 module of the Qt Toolkit.
+**
+** $QT_BEGIN_LICENSE:LGPL3$
+** Commercial License Usage
+** Licensees holding valid commercial Qt licenses may use this file in
+** accordance with the commercial license agreement provided with the
+** Software or, alternatively, in accordance with the terms contained in
+** a written agreement between you and The Qt Company. For licensing terms
+** and conditions see http://www.qt.io/terms-conditions. For further
+** information use the contact form at http://www.qt.io/contact-us.
+**
+** GNU Lesser General Public License Usage
+** Alternatively, this file may be used under the terms of the GNU Lesser
+** General Public License version 3 as published by the Free Software
+** Foundation and appearing in the file LICENSE.LGPLv3 included in the
+** packaging of this file. Please review the following information to
+** ensure the GNU Lesser General Public License version 3 requirements
+** will be met: https://www.gnu.org/licenses/lgpl.html.
+**
+** GNU General Public License Usage
+** Alternatively, this file may be used under the terms of the GNU
+** General Public License version 2.0 or later as published by the Free
+** Software Foundation and appearing in the file LICENSE.GPL included in
+** the packaging of this file. Please review the following information to
+** ensure the GNU General Public License version 2.0 requirements will be
+** met: http://www.gnu.org/licenses/gpl-2.0.html.
+**
+** $QT_END_LICENSE$
+**
+****************************************************************************/
+
+import QtQuick
+import QtQuick.NativeStyle as NativeStyle
+
+NativeStyle.DefaultScrollBar {
+ id: controlRoot
+
+ topPadding: orientation == Qt.Vertical ? 17 : 0
+ bottomPadding: orientation == Qt.Vertical ? 17 : 0
+ leftPadding: orientation == Qt.Horizontal ? 17 : 0
+ rightPadding: orientation == Qt.Horizontal ? 17 : 0
+
+ contentItem: NativeStyle.ScrollBar {
+ control: controlRoot
+ subControl: NativeStyle.ScrollBar.Handle
+ }
+
+ NativeStyle.ScrollBar {
+ // Fade a hovered-looking version of the handle
+ // on top of the default handle when hovering it
+ x: contentItem.x
+ y: contentItem.y
+ z: 1
+ width: contentItem.width
+ height: contentItem.height
+ control: controlRoot
+ subControl: NativeStyle.ScrollBar.Handle
+ overrideState: NativeStyle.StyleItem.AlwaysHovered
+ opacity: controlRoot.hovered || control.pressed ? 1 : 0
+ visible: contentItem instanceof NativeStyle.StyleItem
+ Behavior on opacity { NumberAnimation { duration: contentItem.transitionDuration } }
+ }
+
+ // The groove background should have window color
+ Rectangle {
+ x: background.x
+ y: background.y
+ z: -1
+ width: background.width
+ height: background.height
+ color: controlRoot.palette.window
+ }
+
+ background: NativeStyle.ScrollBar {
+ control: controlRoot
+ subControl: NativeStyle.ScrollBar.Groove
+ overrideState: NativeStyle.ScrollBar.NeverHovered
+ }
+}
diff --git a/src/imports/controls/windows/qmldir b/src/imports/controls/windows/qmldir
index ed9758b3..bc87455d 100644
--- a/src/imports/controls/windows/qmldir
+++ b/src/imports/controls/windows/qmldir
@@ -14,4 +14,5 @@ Frame 6.0 Frame.qml
TextArea 6.0 TextArea.qml
ComboBox 6.0 ComboBox.qml
ProgressBar 6.0 ProgressBar.qml
+ScrollBar 6.0 ScrollBar.qml
ScrollView 6.0 ScrollView.qml
diff --git a/src/imports/controls/windows/windows.pri b/src/imports/controls/windows/windows.pri
index 4c9e51f7..7f13eab0 100644
--- a/src/imports/controls/windows/windows.pri
+++ b/src/imports/controls/windows/windows.pri
@@ -10,4 +10,5 @@ QML_FILES += \
$$PWD/SpinBox.qml \
$$PWD/TextArea.qml \
$$PWD/TextField.qml \
+ $$PWD/ScrollBar.qml \
$$PWD/ScrollView.qml \