aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorRichard Moe Gustavsen <richard.gustavsen@qt.io>2020-08-11 12:37:44 +0200
committerRichard Moe Gustavsen <richard.gustavsen@qt.io>2020-08-12 20:53:41 +0000
commit98668d30cc89239a4c7b8f19d25f6642f66909f0 (patch)
tree3c81e1eded05ce929bd0806cbfb2dff4b9797b05 /src/imports
parentc3c634e0f921047b221b858ef35769aeee245cc9 (diff)
Native style: add configure options
Change-Id: I54521f85aa821369ba3ff57fb037ae4996845c97 Reviewed-by: Mitch Curtis <mitch.curtis@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/controls/macos/CMakeLists.txt1
-rw-r--r--src/imports/controls/macos/macos.pro3
-rw-r--r--src/imports/controls/windows/CMakeLists.txt1
-rw-r--r--src/imports/controls/windows/windows.pro3
-rw-r--r--src/imports/nativestyle/CMakeLists.txt1
-rw-r--r--src/imports/nativestyle/nativestyle.pro3
6 files changed, 6 insertions, 6 deletions
diff --git a/src/imports/controls/macos/CMakeLists.txt b/src/imports/controls/macos/CMakeLists.txt
index 76f87189..211d6871 100644
--- a/src/imports/controls/macos/CMakeLists.txt
+++ b/src/imports/controls/macos/CMakeLists.txt
@@ -39,6 +39,7 @@ qt_add_qml_module(qtquickcontrols2macosstyleplugin
# QML_IMPORT_MAJOR_VERSION = "2"
# QML_IMPORT_NAME = "QtQuick.Controls.macOS"
# TARGETPATH = "QtQuick/Controls.2/macOS"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-macos)"
set(qml_files
"Button.qml"
diff --git a/src/imports/controls/macos/macos.pro b/src/imports/controls/macos/macos.pro
index 3ed55ef8..b8b2c19c 100644
--- a/src/imports/controls/macos/macos.pro
+++ b/src/imports/controls/macos/macos.pro
@@ -23,7 +23,6 @@ CONFIG += qmltypes install_qmltypes
load(qml_plugin)
-# TODO: add config flag
-#requires(qtConfig(quickcontrols2-nativestyle))
+requires(qtConfig(quickcontrols2-macos))
HEADERS +=
diff --git a/src/imports/controls/windows/CMakeLists.txt b/src/imports/controls/windows/CMakeLists.txt
index bede8e30..0470f370 100644
--- a/src/imports/controls/windows/CMakeLists.txt
+++ b/src/imports/controls/windows/CMakeLists.txt
@@ -39,6 +39,7 @@ qt_add_qml_module(qtquickcontrols2windowsstyleplugin
# QML_IMPORT_MAJOR_VERSION = "6"
# QML_IMPORT_NAME = "QtQuick.Controls.Windows"
# TARGETPATH = "QtQuick/Controls.2/Windows"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-windows)"
set(qml_files
"Button.qml"
diff --git a/src/imports/controls/windows/windows.pro b/src/imports/controls/windows/windows.pro
index a19c2e79..d78690ec 100644
--- a/src/imports/controls/windows/windows.pro
+++ b/src/imports/controls/windows/windows.pro
@@ -23,7 +23,6 @@ CONFIG += qmltypes install_qmltypes
load(qml_plugin)
-# TODO: add config flag
-#requires(qtConfig(quickcontrols2-nativestyle))
+requires(qtConfig(quickcontrols2-windows))
HEADERS +=
diff --git a/src/imports/nativestyle/CMakeLists.txt b/src/imports/nativestyle/CMakeLists.txt
index 08c44e7f..ee972a3b 100644
--- a/src/imports/nativestyle/CMakeLists.txt
+++ b/src/imports/nativestyle/CMakeLists.txt
@@ -61,6 +61,7 @@ qt_add_qml_module(qtquickcontrols2nativestyleplugin
# QML_IMPORT_MAJOR_VERSION = "6"
# QML_IMPORT_NAME = "QtQuick.NativeStyle"
# TARGETPATH = "QtQuick/NativeStyle"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-macos)|qtConfig(quickcontrols2-windows)"
## Scopes:
#####################################################################
diff --git a/src/imports/nativestyle/nativestyle.pro b/src/imports/nativestyle/nativestyle.pro
index aa8b28b5..b06e5daf 100644
--- a/src/imports/nativestyle/nativestyle.pro
+++ b/src/imports/nativestyle/nativestyle.pro
@@ -25,7 +25,6 @@ CONFIG += qmltypes install_qmltypes
load(qml_plugin)
-# TODO: add config flag
-#requires(qtConfig(quickcontrols2-nativestyle))
+requires(qtConfig(quickcontrols2-macos)|qtConfig(quickcontrols2-windows))
HEADERS +=