aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols2/imagine/automotive/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quickcontrols2/imagine/automotive/CMakeLists.txt')
-rw-r--r--examples/quickcontrols2/imagine/automotive/CMakeLists.txt208
1 files changed, 104 insertions, 104 deletions
diff --git a/examples/quickcontrols2/imagine/automotive/CMakeLists.txt b/examples/quickcontrols2/imagine/automotive/CMakeLists.txt
index ad417e51..978973be 100644
--- a/examples/quickcontrols2/imagine/automotive/CMakeLists.txt
+++ b/examples/quickcontrols2/imagine/automotive/CMakeLists.txt
@@ -37,31 +37,31 @@ target_link_libraries(automotive PUBLIC
# Resources:
set(icons_resource_files
- "automotive/44x44/air-con.png"
- "automotive/44x44/command.png"
- "automotive/44x44/message.png"
- "automotive/44x44/music.png"
- "automotive/44x44/seats.png"
- "automotive/44x44/settings.png"
- "automotive/44x44/statistics.png"
- "automotive/44x44/windows.png"
- "automotive/44x44@2/air-con.png"
- "automotive/44x44@2/command.png"
- "automotive/44x44@2/message.png"
- "automotive/44x44@2/music.png"
- "automotive/44x44@2/navigation.png"
- "automotive/44x44@2/seats.png"
- "automotive/44x44@2/settings.png"
- "automotive/44x44@2/statistics.png"
- "automotive/44x44@2/windows.png"
- "automotive/icons.svg"
- "automotive/index.theme"
- "car.png"
- "car@2x.png"
- "warning.png"
- "warning@2x.png"
- "weather.png"
- "weather@2x.png"
+ "icons/automotive/44x44/air-con.png"
+ "icons/automotive/44x44/command.png"
+ "icons/automotive/44x44/message.png"
+ "icons/automotive/44x44/music.png"
+ "icons/automotive/44x44/seats.png"
+ "icons/automotive/44x44/settings.png"
+ "icons/automotive/44x44/statistics.png"
+ "icons/automotive/44x44/windows.png"
+ "icons/automotive/44x44@2/air-con.png"
+ "icons/automotive/44x44@2/command.png"
+ "icons/automotive/44x44@2/message.png"
+ "icons/automotive/44x44@2/music.png"
+ "icons/automotive/44x44@2/navigation.png"
+ "icons/automotive/44x44@2/seats.png"
+ "icons/automotive/44x44@2/settings.png"
+ "icons/automotive/44x44@2/statistics.png"
+ "icons/automotive/44x44@2/windows.png"
+ "icons/automotive/icons.svg"
+ "icons/automotive/index.theme"
+ "icons/car.png"
+ "icons/car@2x.png"
+ "icons/warning.png"
+ "icons/warning@2x.png"
+ "icons/weather.png"
+ "icons/weather@2x.png"
)
qt6_add_resources(automotive "icons"
@@ -73,82 +73,82 @@ qt6_add_resources(automotive "icons"
${icons_resource_files}
)
set(imagine-assets_resource_files
- "applicationwindow-background.png"
- "applicationwindow-background@2x.png"
- "button-background-checked-hovered.9.png"
- "button-background-checked-hovered@2x.9.png"
- "button-background-checked.9.png"
- "button-background-checked@2x.9.png"
- "button-background-hovered.9.png"
- "button-background-hovered@2x.9.png"
- "button-background-pressed.9.png"
- "button-background-pressed@2x.9.png"
- "button-background.9.png"
- "button-background@2x.9.png"
- "dial-background-hovered.png"
- "dial-background-hovered@2x.png"
- "dial-background-pressed.png"
- "dial-background-pressed@2x.png"
- "dial-background.png"
- "dial-background@2x.png"
- "dial-handle-pressed.png"
- "dial-handle-pressed@2x.png"
- "dial-handle.png"
- "dial-handle@2x.png"
- "frame-background.9.png"
- "frame-background@2x.9.png"
- "itemdelegate-background-checked.9.png"
- "itemdelegate-background-checked@2x.9.png"
- "itemdelegate-background-hovered.9.png"
- "itemdelegate-background-hovered@2x.9.png"
- "itemdelegate-background-pressed.9.png"
- "itemdelegate-background-pressed@2x.9.png"
- "itemdelegate-background.9.png"
- "itemdelegate-background@2x.9.png"
- "radiobutton-indicator-checked-hovered.png"
- "radiobutton-indicator-checked-hovered@2x.png"
- "radiobutton-indicator-checked-pressed.png"
- "radiobutton-indicator-checked-pressed@2x.png"
- "radiobutton-indicator-checked.png"
- "radiobutton-indicator-checked@2x.png"
- "radiobutton-indicator-hovered.png"
- "radiobutton-indicator-hovered@2x.png"
- "radiobutton-indicator-pressed.png"
- "radiobutton-indicator-pressed@2x.png"
- "radiobutton-indicator.png"
- "radiobutton-indicator@2x.png"
- "scrollindicator-handle.png"
- "scrollindicator-handle@2x.png"
- "slider-background-horizontal.9.png"
- "slider-background-horizontal@2x.9.png"
- "slider-handle-hovered.png"
- "slider-handle-hovered@2x.png"
- "slider-handle-pressed.png"
- "slider-handle-pressed@2x.png"
- "slider-handle.png"
- "slider-handle@2x.png"
- "slider-progress-horizontal-pressed.9.png"
- "slider-progress-horizontal-pressed@2x.9.png"
- "slider-progress-horizontal.9.png"
- "slider-progress-horizontal@2x.9.png"
- "switchdelegate-background.9.png"
- "switchdelegate-background@2x.9.png"
- "switchdelegate-handle-checked-hovered.png"
- "switchdelegate-handle-checked-hovered@2x.png"
- "switchdelegate-handle-checked.png"
- "switchdelegate-handle-checked@2x.png"
- "switchdelegate-handle-hovered.png"
- "switchdelegate-handle-hovered@2x.png"
- "switchdelegate-handle-pressed.png"
- "switchdelegate-handle-pressed@2x.png"
- "switchdelegate-handle.png"
- "switchdelegate-handle@2x.png"
- "switchdelegate-indicator-pressed.png"
- "switchdelegate-indicator-pressed@2x.png"
- "switchdelegate-indicator.png"
- "switchdelegate-indicator@2x.png"
- "toolseparator-separator-vertical.9.png"
- "toolseparator-separator-vertical@2x.9.png"
+ "imagine-assets/applicationwindow-background.png"
+ "imagine-assets/applicationwindow-background@2x.png"
+ "imagine-assets/button-background-checked-hovered.9.png"
+ "imagine-assets/button-background-checked-hovered@2x.9.png"
+ "imagine-assets/button-background-checked.9.png"
+ "imagine-assets/button-background-checked@2x.9.png"
+ "imagine-assets/button-background-hovered.9.png"
+ "imagine-assets/button-background-hovered@2x.9.png"
+ "imagine-assets/button-background-pressed.9.png"
+ "imagine-assets/button-background-pressed@2x.9.png"
+ "imagine-assets/button-background.9.png"
+ "imagine-assets/button-background@2x.9.png"
+ "imagine-assets/dial-background-hovered.png"
+ "imagine-assets/dial-background-hovered@2x.png"
+ "imagine-assets/dial-background-pressed.png"
+ "imagine-assets/dial-background-pressed@2x.png"
+ "imagine-assets/dial-background.png"
+ "imagine-assets/dial-background@2x.png"
+ "imagine-assets/dial-handle-pressed.png"
+ "imagine-assets/dial-handle-pressed@2x.png"
+ "imagine-assets/dial-handle.png"
+ "imagine-assets/dial-handle@2x.png"
+ "imagine-assets/frame-background.9.png"
+ "imagine-assets/frame-background@2x.9.png"
+ "imagine-assets/itemdelegate-background-checked.9.png"
+ "imagine-assets/itemdelegate-background-checked@2x.9.png"
+ "imagine-assets/itemdelegate-background-hovered.9.png"
+ "imagine-assets/itemdelegate-background-hovered@2x.9.png"
+ "imagine-assets/itemdelegate-background-pressed.9.png"
+ "imagine-assets/itemdelegate-background-pressed@2x.9.png"
+ "imagine-assets/itemdelegate-background.9.png"
+ "imagine-assets/itemdelegate-background@2x.9.png"
+ "imagine-assets/radiobutton-indicator-checked-hovered.png"
+ "imagine-assets/radiobutton-indicator-checked-hovered@2x.png"
+ "imagine-assets/radiobutton-indicator-checked-pressed.png"
+ "imagine-assets/radiobutton-indicator-checked-pressed@2x.png"
+ "imagine-assets/radiobutton-indicator-checked.png"
+ "imagine-assets/radiobutton-indicator-checked@2x.png"
+ "imagine-assets/radiobutton-indicator-hovered.png"
+ "imagine-assets/radiobutton-indicator-hovered@2x.png"
+ "imagine-assets/radiobutton-indicator-pressed.png"
+ "imagine-assets/radiobutton-indicator-pressed@2x.png"
+ "imagine-assets/radiobutton-indicator.png"
+ "imagine-assets/radiobutton-indicator@2x.png"
+ "imagine-assets/scrollindicator-handle.png"
+ "imagine-assets/scrollindicator-handle@2x.png"
+ "imagine-assets/slider-background-horizontal.9.png"
+ "imagine-assets/slider-background-horizontal@2x.9.png"
+ "imagine-assets/slider-handle-hovered.png"
+ "imagine-assets/slider-handle-hovered@2x.png"
+ "imagine-assets/slider-handle-pressed.png"
+ "imagine-assets/slider-handle-pressed@2x.png"
+ "imagine-assets/slider-handle.png"
+ "imagine-assets/slider-handle@2x.png"
+ "imagine-assets/slider-progress-horizontal-pressed.9.png"
+ "imagine-assets/slider-progress-horizontal-pressed@2x.9.png"
+ "imagine-assets/slider-progress-horizontal.9.png"
+ "imagine-assets/slider-progress-horizontal@2x.9.png"
+ "imagine-assets/switchdelegate-background.9.png"
+ "imagine-assets/switchdelegate-background@2x.9.png"
+ "imagine-assets/switchdelegate-handle-checked-hovered.png"
+ "imagine-assets/switchdelegate-handle-checked-hovered@2x.png"
+ "imagine-assets/switchdelegate-handle-checked.png"
+ "imagine-assets/switchdelegate-handle-checked@2x.png"
+ "imagine-assets/switchdelegate-handle-hovered.png"
+ "imagine-assets/switchdelegate-handle-hovered@2x.png"
+ "imagine-assets/switchdelegate-handle-pressed.png"
+ "imagine-assets/switchdelegate-handle-pressed@2x.png"
+ "imagine-assets/switchdelegate-handle.png"
+ "imagine-assets/switchdelegate-handle@2x.png"
+ "imagine-assets/switchdelegate-indicator-pressed.png"
+ "imagine-assets/switchdelegate-indicator-pressed@2x.png"
+ "imagine-assets/switchdelegate-indicator.png"
+ "imagine-assets/switchdelegate-indicator@2x.png"
+ "imagine-assets/toolseparator-separator-vertical.9.png"
+ "imagine-assets/toolseparator-separator-vertical@2x.9.png"
)
qt6_add_resources(automotive "imagine-assets"
@@ -160,9 +160,9 @@ qt6_add_resources(automotive "imagine-assets"
${imagine-assets_resource_files}
)
set(qml_resource_files
- "FeatureButton.qml"
- "LargeLabel.qml"
- "automotive.qml"
+ "qml/FeatureButton.qml"
+ "qml/LargeLabel.qml"
+ "qml/automotive.qml"
)
qt6_add_resources(automotive "qml"