aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/fusion/.prev_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/controls/fusion/.prev_CMakeLists.txt')
-rw-r--r--src/imports/controls/fusion/.prev_CMakeLists.txt172
1 files changed, 154 insertions, 18 deletions
diff --git a/src/imports/controls/fusion/.prev_CMakeLists.txt b/src/imports/controls/fusion/.prev_CMakeLists.txt
index 4c59e4f6..b9d5e58b 100644
--- a/src/imports/controls/fusion/.prev_CMakeLists.txt
+++ b/src/imports/controls/fusion/.prev_CMakeLists.txt
@@ -4,18 +4,14 @@
## qtquickcontrols2fusionstyleplugin Plugin:
#####################################################################
-add_qml_module(qtquickcontrols2fusionstyleplugin
- TARGET_PATH "QtQuick/Controls/Fusion"
+qt_add_qml_module(qtquickcontrols2fusionstyleplugin
URI "QtQuick.Controls.Fusion"
- VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickControls2FusionStylePlugin
- DEPENDENCIES
- QtQuick.Controls/2.5
- SKIP_TYPE_REGISTRATION
+ IMPORTS
+ QtQuick.Controls.Default/auto
+ GENERATE_QMLTYPES
SOURCES
- qquickfusionbusyindicator.cpp qquickfusionbusyindicator_p.h
- qquickfusiondial.cpp qquickfusiondial_p.h
- qquickfusionknob.cpp qquickfusionknob_p.h
qquickfusionstyle.cpp qquickfusionstyle_p.h
qquickfusiontheme.cpp qquickfusiontheme_p.h
qtquickcontrols2fusionstyleplugin.cpp
@@ -52,7 +48,7 @@ set(qtquickcontrols2fusionstyle_resource_files
"images/progressmask@4x.png"
)
-add_qt_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
+qt_add_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
PREFIX
"/qt-project.org/imports/QtQuick/Controls/Fusion"
FILES
@@ -61,9 +57,9 @@ add_qt_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
#### Keys ignored in scope 1:.:.:fusion.pro:<TRUE>:
-# IMPORT_NAME = "QtQuick.Controls.Fusion"
-# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
+# QML_IMPORT_NAME = "QtQuick.Controls.Fusion"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
# TARGETPATH = "QtQuick/Controls/Fusion"
# _REQUIREMENTS = "qtConfig(quickcontrols2-fusion)"
@@ -71,10 +67,8 @@ set(qml_files
"ApplicationWindow.qml"
"BusyIndicator.qml"
"Button.qml"
- "ButtonPanel.qml"
"CheckBox.qml"
"CheckDelegate.qml"
- "CheckIndicator.qml"
"ComboBox.qml"
"DelayButton.qml"
"Dial.qml"
@@ -83,6 +77,7 @@ set(qml_files
"Drawer.qml"
"Frame.qml"
"GroupBox.qml"
+ "HorizontalHeaderView.qml"
"ItemDelegate.qml"
"Label.qml"
"Menu.qml"
@@ -97,19 +92,15 @@ set(qml_files
"ProgressBar.qml"
"RadioButton.qml"
"RadioDelegate.qml"
- "RadioIndicator.qml"
"RangeSlider.qml"
"RoundButton.qml"
"ScrollBar.qml"
"ScrollIndicator.qml"
"Slider.qml"
- "SliderGroove.qml"
- "SliderHandle.qml"
"SpinBox.qml"
"SplitView.qml"
"SwipeDelegate.qml"
"SwitchDelegate.qml"
- "SwitchIndicator.qml"
"Switch.qml"
"TabBar.qml"
"TabButton.qml"
@@ -120,6 +111,151 @@ set(qml_files
"ToolSeparator.qml"
"ToolTip.qml"
"Tumbler.qml"
+ "VerticalHeaderView.qml"
+)
+set_source_files_properties(ApplicationWindow.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(BusyIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Button.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(CheckBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(CheckDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ComboBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(DelayButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.2;6.0"
+)
+set_source_files_properties(Dial.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Dialog.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(DialogButtonBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(Drawer.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Frame.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(GroupBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(HorizontalHeaderView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.15;6.0"
+)
+set_source_files_properties(ItemDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Label.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Menu.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(MenuBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(MenuBarItem.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(MenuItem.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(MenuSeparator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(Page.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(PageIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Pane.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Popup.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ProgressBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RadioButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RadioDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RangeSlider.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RoundButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(ScrollBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ScrollIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Slider.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SpinBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SplitView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.13;6.0"
+)
+set_source_files_properties(SwipeDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SwitchDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Switch.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TabBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TabButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TextArea.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TextField.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolSeparator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(ToolTip.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Tumbler.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(VerticalHeaderView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.15;6.0"
)
qt6_target_qml_files(qtquickcontrols2fusionstyleplugin