aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/macos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/controls/macos/CMakeLists.txt')
-rw-r--r--src/imports/controls/macos/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/imports/controls/macos/CMakeLists.txt b/src/imports/controls/macos/CMakeLists.txt
index 1cb9ff86..ca335f34 100644
--- a/src/imports/controls/macos/CMakeLists.txt
+++ b/src/imports/controls/macos/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2macosstyleplugin Plugin:
#####################################################################
-qt_add_qml_module(qtquickcontrols2macosstyleplugin
+qt_internal_add_qml_module(qtquickcontrols2macosstyleplugin
URI "QtQuick.Controls.macOS"
VERSION "6.0" # special case
CLASSNAME QtQuickControls2MacOSStylePlugin
@@ -85,6 +85,9 @@ set_source_files_properties(TextArea.qml PROPERTIES
set_source_files_properties(ComboBox.qml PROPERTIES
QT_QML_SOURCE_VERSION "6.0"
)
+set_source_files_properties(ScrollView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
set_source_files_properties(ScrollBar.qml PROPERTIES
QT_QML_SOURCE_VERSION "6.0"
)