aboutsummaryrefslogtreecommitdiffstats
path: root/src/quickcontrols2/fusion/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/quickcontrols2/fusion/CMakeLists.txt')
-rw-r--r--src/quickcontrols2/fusion/CMakeLists.txt249
1 files changed, 0 insertions, 249 deletions
diff --git a/src/quickcontrols2/fusion/CMakeLists.txt b/src/quickcontrols2/fusion/CMakeLists.txt
deleted file mode 100644
index 56f98908..00000000
--- a/src/quickcontrols2/fusion/CMakeLists.txt
+++ /dev/null
@@ -1,249 +0,0 @@
-#####################################################################
-## qtquickcontrols2fusionstyleplugin Plugin:
-#####################################################################
-
-set(qml_files
- "ApplicationWindow.qml"
- "BusyIndicator.qml"
- "Button.qml"
- "CheckBox.qml"
- "CheckDelegate.qml"
- "ComboBox.qml"
- "DelayButton.qml"
- "Dial.qml"
- "Dialog.qml"
- "DialogButtonBox.qml"
- "Drawer.qml"
- "Frame.qml"
- "GroupBox.qml"
- "HorizontalHeaderView.qml"
- "ItemDelegate.qml"
- "Label.qml"
- "Menu.qml"
- "MenuBar.qml"
- "MenuBarItem.qml"
- "MenuItem.qml"
- "MenuSeparator.qml"
- "Page.qml"
- "PageIndicator.qml"
- "Pane.qml"
- "Popup.qml"
- "ProgressBar.qml"
- "RadioButton.qml"
- "RadioDelegate.qml"
- "RangeSlider.qml"
- "RoundButton.qml"
- "ScrollBar.qml"
- "ScrollView.qml"
- "ScrollIndicator.qml"
- "Slider.qml"
- "SpinBox.qml"
- "SplitView.qml"
- "SwipeDelegate.qml"
- "SwitchDelegate.qml"
- "Switch.qml"
- "TabBar.qml"
- "TabButton.qml"
- "TextArea.qml"
- "TextField.qml"
- "ToolBar.qml"
- "ToolButton.qml"
- "ToolSeparator.qml"
- "ToolTip.qml"
- "Tumbler.qml"
- "VerticalHeaderView.qml"
-)
-set_source_files_properties(ApplicationWindow.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(BusyIndicator.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Button.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(CheckBox.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(CheckDelegate.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(ComboBox.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(DelayButton.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.2;6.0"
-)
-set_source_files_properties(Dial.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Dialog.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.1;6.0"
-)
-set_source_files_properties(DialogButtonBox.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.1;6.0"
-)
-set_source_files_properties(Drawer.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Frame.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(GroupBox.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(HorizontalHeaderView.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.15;6.0"
-)
-set_source_files_properties(ItemDelegate.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Label.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Menu.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(MenuBar.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.3;6.0"
-)
-set_source_files_properties(MenuBarItem.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.3;6.0"
-)
-set_source_files_properties(MenuItem.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(MenuSeparator.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.1;6.0"
-)
-set_source_files_properties(Page.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(PageIndicator.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Pane.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Popup.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(ProgressBar.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(RadioButton.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(RadioDelegate.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(RangeSlider.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(RoundButton.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.1;6.0"
-)
-set_source_files_properties(ScrollBar.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(ScrollView.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(ScrollIndicator.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Slider.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(SpinBox.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(SplitView.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.13;6.0"
-)
-set_source_files_properties(SwipeDelegate.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(SwitchDelegate.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Switch.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(TabBar.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(TabButton.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(TextArea.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(TextField.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(ToolBar.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(ToolButton.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(ToolSeparator.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.1;6.0"
-)
-set_source_files_properties(ToolTip.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(Tumbler.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.0;6.0"
-)
-set_source_files_properties(VerticalHeaderView.qml PROPERTIES
- QT_QML_SOURCE_VERSION "2.15;6.0"
-)
-
-qt_internal_add_qml_module(qtquickcontrols2fusionstyleplugin
- URI "QtQuick.Controls.Fusion"
- VERSION "${PROJECT_VERSION}"
- CLASS_NAME QtQuickControls2FusionStylePlugin
- IMPORTS
- QtQuick.Controls.Basic/auto
- PLUGIN_TARGET qtquickcontrols2fusionstyleplugin
- NO_PLUGIN_OPTIONAL
- NO_GENERATE_PLUGIN_SOURCE
- SOURCES
- qquickfusionstyle.cpp qquickfusionstyle_p.h
- qquickfusiontheme.cpp qquickfusiontheme_p.h
- qtquickcontrols2fusionstyleplugin.cpp
- QML_FILES
- ${qml_files}
- DEFINES
- QT_NO_CAST_FROM_ASCII
- QT_NO_CAST_TO_ASCII
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::QmlPrivate
- Qt::QuickControls2Private
- Qt::QuickPrivate
- Qt::QuickTemplates2Private
-)
-
-qt_internal_add_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
- PREFIX
- "/qt-project.org/imports/QtQuick/Controls/Fusion"
- FILES
- "images/arrow.png"
- "images/arrow@2x.png"
- "images/arrow@3x.png"
- "images/arrow@4x.png"
- "images/checkmark.png"
- "images/checkmark@2x.png"
- "images/checkmark@3x.png"
- "images/checkmark@4x.png"
- "images/progressmask.png"
- "images/progressmask@2x.png"
- "images/progressmask@3x.png"
- "images/progressmask@4x.png"
-)
-
-add_subdirectory(impl)