aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/calendar/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/calendar/CMakeLists.txt')
-rw-r--r--tests/auto/calendar/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/auto/calendar/CMakeLists.txt b/tests/auto/calendar/CMakeLists.txt
new file mode 100644
index 00000000..f729018f
--- /dev/null
+++ b/tests/auto/calendar/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from calendar.pro.
+
+#####################################################################
+## tst_calendar Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/data/tst_*)
+list(APPEND test_data ${test_data_glob})
+
+add_qt_test(tst_calendar
+ GUI
+ QMLTEST
+ SOURCES
+ tst_calendar.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ TESTDATA ${test_data}
+)
+
+#### Keys ignored in scope 1:.:.:calendar.pro:<TRUE>:
+# OTHER_FILES = "$$PWD/data/*.qml"
+# TEMPLATE = "app"