aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qquickpopup/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qquickpopup/CMakeLists.txt')
-rw-r--r--tests/auto/qquickpopup/CMakeLists.txt16
1 files changed, 6 insertions, 10 deletions
diff --git a/tests/auto/qquickpopup/CMakeLists.txt b/tests/auto/qquickpopup/CMakeLists.txt
index 7f2c38e9..beb744a7 100644
--- a/tests/auto/qquickpopup/CMakeLists.txt
+++ b/tests/auto/qquickpopup/CMakeLists.txt
@@ -10,7 +10,7 @@ file(GLOB_RECURSE test_data_glob
data/*)
list(APPEND test_data ${test_data_glob})
-add_qt_test(tst_qquickpopup
+qt_add_test(tst_qquickpopup
SOURCES
../shared/qtest_quickcontrols.h
../shared/util.cpp ../shared/util.h
@@ -18,19 +18,15 @@ add_qt_test(tst_qquickpopup
tst_qquickpopup.cpp
DEFINES
QQC2_IMPORT_PATH=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../../src/imports\\\"
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
+ Qt::Gui
Qt::GuiPrivate
Qt::QmlPrivate
+ Qt::QuickControls2
Qt::QuickPrivate
Qt::QuickTemplates2Private
Qt::TestPrivate
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::Qml
- Qt::Quick
- Qt::QuickControls2
- Qt::QuickTemplates2
TESTDATA ${test_data}
)
@@ -40,12 +36,12 @@ add_qt_test(tst_qquickpopup
## Scopes:
#####################################################################
-extend_target(tst_qquickpopup CONDITION ANDROID OR APPLE_IOS
+qt_extend_target(tst_qquickpopup CONDITION ANDROID OR IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"
)
-extend_target(tst_qquickpopup CONDITION NOT ANDROID AND NOT APPLE_IOS
+qt_extend_target(tst_qquickpopup CONDITION NOT ANDROID AND NOT IOS
DEFINES
QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
)