aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qquickpopup/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qquickpopup/CMakeLists.txt')
-rw-r--r--tests/auto/qquickpopup/CMakeLists.txt14
1 files changed, 5 insertions, 9 deletions
diff --git a/tests/auto/qquickpopup/CMakeLists.txt b/tests/auto/qquickpopup/CMakeLists.txt
index 7df9ac8a..beb744a7 100644
--- a/tests/auto/qquickpopup/CMakeLists.txt
+++ b/tests/auto/qquickpopup/CMakeLists.txt
@@ -18,19 +18,15 @@ qt_add_test(tst_qquickpopup
tst_qquickpopup.cpp
DEFINES
QQC2_IMPORT_PATH=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../../src/imports\\\"
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
+ Qt::Gui
Qt::GuiPrivate
Qt::QmlPrivate
+ Qt::QuickControls2
Qt::QuickPrivate
Qt::QuickTemplates2Private
Qt::TestPrivate
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::Qml
- Qt::Quick
- Qt::QuickControls2
- Qt::QuickTemplates2
TESTDATA ${test_data}
)
@@ -40,12 +36,12 @@ qt_add_test(tst_qquickpopup
## Scopes:
#####################################################################
-qt_extend_target(tst_qquickpopup CONDITION ANDROID OR APPLE_IOS
+qt_extend_target(tst_qquickpopup CONDITION ANDROID OR IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"
)
-qt_extend_target(tst_qquickpopup CONDITION NOT ANDROID AND NOT APPLE_IOS
+qt_extend_target(tst_qquickpopup CONDITION NOT ANDROID AND NOT IOS
DEFINES
QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
)