aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/snippets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/snippets/CMakeLists.txt')
-rw-r--r--tests/auto/snippets/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/auto/snippets/CMakeLists.txt b/tests/auto/snippets/CMakeLists.txt
new file mode 100644
index 00000000..f5d60a40
--- /dev/null
+++ b/tests/auto/snippets/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from snippets.pro.
+
+#####################################################################
+## tst_snippets Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/data/*)
+list(APPEND test_data ${test_data_glob})
+
+qt_add_test(tst_snippets
+ SOURCES
+ tst_snippets.cpp
+ DEFINES
+ QQC2_SNIPPETS_PATH=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../../src/imports/controls/doc/snippets\\\"
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Quick
+ Qt::QuickControls2
+ TESTDATA ${test_data}
+)
+
+#### Keys ignored in scope 1:.:.:snippets.pro:<TRUE>:
+# OTHER_FILES = "$$PWD/data/*.qml"
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################