aboutsummaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/creationtime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/benchmarks/creationtime/CMakeLists.txt')
-rw-r--r--tests/benchmarks/creationtime/CMakeLists.txt17
1 files changed, 7 insertions, 10 deletions
diff --git a/tests/benchmarks/creationtime/CMakeLists.txt b/tests/benchmarks/creationtime/CMakeLists.txt
index d1365266..1162bace 100644
--- a/tests/benchmarks/creationtime/CMakeLists.txt
+++ b/tests/benchmarks/creationtime/CMakeLists.txt
@@ -4,7 +4,7 @@
## tst_creationtime Test:
#####################################################################
-add_qt_test(tst_creationtime
+qt_add_test(tst_creationtime
SOURCES
../../auto/shared/qtest_quickcontrols.h
../../auto/shared/util.cpp ../../auto/shared/util.h
@@ -12,19 +12,16 @@ add_qt_test(tst_creationtime
tst_creationtime.cpp
DEFINES
QQC2_IMPORT_PATH=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../../src/imports\\\"
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
+ Qt::Gui
Qt::GuiPrivate
+ Qt::Qml
Qt::QmlPrivate
+ Qt::QuickControls2
Qt::QuickPrivate
Qt::QuickTemplates2Private
Qt::TestPrivate
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::Qml
- Qt::Quick
- Qt::QuickControls2
- Qt::QuickTemplates2
)
#### Keys ignored in scope 1:.:.:creationtime.pro:<TRUE>:
@@ -33,12 +30,12 @@ add_qt_test(tst_creationtime
## Scopes:
#####################################################################
-extend_target(tst_creationtime CONDITION ANDROID OR APPLE_IOS
+qt_extend_target(tst_creationtime CONDITION ANDROID OR IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"
)
-extend_target(tst_creationtime CONDITION NOT ANDROID AND NOT APPLE_IOS
+qt_extend_target(tst_creationtime CONDITION NOT ANDROID AND NOT IOS
DEFINES
QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
)