summaryrefslogtreecommitdiffstats
path: root/examples/remoteobjects/websockets/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-02-14 19:08:41 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-03-02 08:08:51 +0000
commit06d20607abf451938898a12ee1ed84d07cc64cea (patch)
tree7fd9378aedf88fbe6fb2566b280b6032b0c1bf84 /examples/remoteobjects/websockets/CMakeLists.txt
parent7d13fda3b0a7c6417b2ac23f5befa2bd3bce2674 (diff)
Improve examples CMakeLists.txt
- Remove # generated from xyz.pro comment from pro2cmake - Remove "# special case" markers for pro2cmake - Remove automatic use of CMAKE_AUTORCC - Only opt into CMAKE_AUTOUIC if .ui files are involved - Remove explicit setting of CMAKE_INCLUDE_CURRENT_DIR, if not required by qt6_add_repc-* - Combine multiple find_package(Qt6 ... calls) - use REQUIRED COMPONENTS - sort components alphabetically - Fix wrong indentations - Use (only) one empty line after multi-line commands Change-Id: Idd8ad59c9f5dd9a6675ef83d589ad2e6d3e0a9c0 Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io> (cherry picked from commit ea67ddbd467f0fd734c8772a0ec4753dd1015d1a) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/remoteobjects/websockets/CMakeLists.txt')
-rw-r--r--examples/remoteobjects/websockets/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/examples/remoteobjects/websockets/CMakeLists.txt b/examples/remoteobjects/websockets/CMakeLists.txt
index 09ff32c..5441f66 100644
--- a/examples/remoteobjects/websockets/CMakeLists.txt
+++ b/examples/remoteobjects/websockets/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from websockets.pro.
-
if(TARGET Qt::WebSockets AND TARGET Qt::Widgets)
qt_internal_add_example(wsclient)
qt_internal_add_example(wsserver)