summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2019-09-17 14:12:29 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2019-09-26 19:39:39 +0000
commit5fe75751ed90354eb0968f528974592003c65460 (patch)
tree34289c653ea7f8c0d891aee0ca6a4be1427bc04d /CMakeLists.txt
parentb5daa31da99fbe872b4df047f37da17ae2c119c9 (diff)
Port QtScxml to CMake
Change-Id: I227f18b6a9825b6974eab6ba9feaf62bd0934133 Reviewed-by: Qt CMake Build Bot Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ed52112
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Generated from qtscxml.pro.
+
+cmake_minimum_required(VERSION 3.15.0)
+
+project(QtScxml
+ VERSION 6.0.0
+ DESCRIPTION "Qt Scxml Libraries"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+# special case begin
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Qml Gui)
+# special case end
+
+qt_build_repo()