summaryrefslogtreecommitdiffstats
path: root/examples/statemachine/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@qt.io>2023-02-23 18:25:27 +0200
committerJuha Vuolle <juha.vuolle@qt.io>2023-03-10 13:30:05 +0200
commitf00f576c95fc99e9bfebdb5d6e321360db1b7eef (patch)
tree0787858fb97aba553109aa6a08aa4642e95b16ab /examples/statemachine/CMakeLists.txt
parent236d927705defbf58a6b410befcf73a141d06c4e (diff)
Flatten the state machine example directory structure
The split into "animation" "graphicsview" and "statemachine" sub-directories is a reminiscent of the times when the examples were in qtcore, and as such not very meaningful when state machine is in a separate repository. In addition remove similarly inherited READMEs. Pick-to: 6.5.0 6.5 Task-number: QTBUG-111447 Change-Id: I8f3d977512fdc239bf3dede341f69788df0a09f4 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'examples/statemachine/CMakeLists.txt')
-rw-r--r--examples/statemachine/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/examples/statemachine/CMakeLists.txt b/examples/statemachine/CMakeLists.txt
index 5da90e2..86db7fb 100644
--- a/examples/statemachine/CMakeLists.txt
+++ b/examples/statemachine/CMakeLists.txt
@@ -1,10 +1,12 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-add_subdirectory(statemachine)
+qt_internal_add_example(pingpong)
if(TARGET Qt::Widgets)
+ qt_internal_add_example(rogue)
+ qt_internal_add_example(trafficlight)
if(QT_FEATURE_animation)
- add_subdirectory(animation)
+ qt_internal_add_example(moveblocks)
endif()
endif()