summaryrefslogtreecommitdiffstats
path: root/examples/statemachine/animation/states/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@insta.fi>2021-02-12 14:31:23 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-02-17 14:31:08 +0000
commit656a25f8bfbc5f698bb9273dfb5edecf62e23cbc (patch)
tree2b4f48533d76b5a685096eeb3487d76679199123 /examples/statemachine/animation/states/CMakeLists.txt
parentd1d0bc2f932c6e847338a1ce8934e42758963bf2 (diff)
Rename example directory (all examples in it are statemachine examples)
Task-number: QTBUG-89833 Change-Id: I5703667054d5f32633c741f97c2890b64801960c Reviewed-by: Paul Wicking <paul.wicking@qt.io> (cherry picked from commit bf411290440543e66c5468018681d041d0b9d047) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/statemachine/animation/states/CMakeLists.txt')
-rw-r--r--examples/statemachine/animation/states/CMakeLists.txt59
1 files changed, 59 insertions, 0 deletions
diff --git a/examples/statemachine/animation/states/CMakeLists.txt b/examples/statemachine/animation/states/CMakeLists.txt
new file mode 100644
index 0000000..26f3192
--- /dev/null
+++ b/examples/statemachine/animation/states/CMakeLists.txt
@@ -0,0 +1,59 @@
+# Generated from states.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(states LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/animation/states")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS StateMachine)
+find_package(Qt6 COMPONENTS Widgets)
+
+qt_add_executable(states
+ main.cpp
+)
+set_target_properties(states PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(states PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::StateMachine
+ Qt::Widgets
+)
+
+
+# Resources:
+set(states_resource_files
+ "accessories-dictionary.png"
+ "akregator.png"
+ "digikam.png"
+ "help-browser.png"
+ "k3b.png"
+ "kchart.png"
+)
+
+qt6_add_resources(states "states"
+ PREFIX
+ "/"
+ FILES
+ ${states_resource_files}
+)
+
+install(TARGETS states
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)