summaryrefslogtreecommitdiffstats
path: root/examples/statemachine/statemachine/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@insta.fi>2021-02-12 14:31:23 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-02-17 14:31:08 +0000
commit656a25f8bfbc5f698bb9273dfb5edecf62e23cbc (patch)
tree2b4f48533d76b5a685096eeb3487d76679199123 /examples/statemachine/statemachine/CMakeLists.txt
parentd1d0bc2f932c6e847338a1ce8934e42758963bf2 (diff)
Rename example directory (all examples in it are statemachine examples)
Task-number: QTBUG-89833 Change-Id: I5703667054d5f32633c741f97c2890b64801960c Reviewed-by: Paul Wicking <paul.wicking@qt.io> (cherry picked from commit bf411290440543e66c5468018681d041d0b9d047) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/statemachine/statemachine/CMakeLists.txt')
-rw-r--r--examples/statemachine/statemachine/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/statemachine/statemachine/CMakeLists.txt b/examples/statemachine/statemachine/CMakeLists.txt
new file mode 100644
index 0000000..90a7b3e
--- /dev/null
+++ b/examples/statemachine/statemachine/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Generated from statemachine.pro.
+
+add_subdirectory(factorial)
+add_subdirectory(pingpong)
+if(TARGET Qt::Widgets)
+ add_subdirectory(eventtransitions)
+ add_subdirectory(rogue)
+ add_subdirectory(trafficlight)
+ add_subdirectory(twowaybutton)
+endif()