summaryrefslogtreecommitdiffstats
path: root/examples/statemachine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/statemachine/CMakeLists.txt')
-rw-r--r--examples/statemachine/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/examples/statemachine/CMakeLists.txt b/examples/statemachine/CMakeLists.txt
index 5da90e2..86db7fb 100644
--- a/examples/statemachine/CMakeLists.txt
+++ b/examples/statemachine/CMakeLists.txt
@@ -1,10 +1,12 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-add_subdirectory(statemachine)
+qt_internal_add_example(pingpong)
if(TARGET Qt::Widgets)
+ qt_internal_add_example(rogue)
+ qt_internal_add_example(trafficlight)
if(QT_FEATURE_animation)
- add_subdirectory(animation)
+ qt_internal_add_example(moveblocks)
endif()
endif()