summaryrefslogtreecommitdiffstats
path: root/examples/statemachine/animation/stickman/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/statemachine/animation/stickman/CMakeLists.txt')
-rw-r--r--examples/statemachine/animation/stickman/CMakeLists.txt58
1 files changed, 0 insertions, 58 deletions
diff --git a/examples/statemachine/animation/stickman/CMakeLists.txt b/examples/statemachine/animation/stickman/CMakeLists.txt
deleted file mode 100644
index cb874c1..0000000
--- a/examples/statemachine/animation/stickman/CMakeLists.txt
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(stickman LANGUAGES CXX)
-
-set(CMAKE_AUTOMOC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/animation/stickman")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui StateMachine Widgets)
-
-qt_add_executable(stickman
- animation.cpp animation.h
- graphicsview.cpp graphicsview.h
- lifecycle.cpp lifecycle.h
- main.cpp
- node.cpp node.h
- rectbutton.cpp rectbutton.h
- stickman.cpp stickman.h
-)
-
-set_target_properties(stickman PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(stickman PUBLIC
- Qt::Core
- Qt::Gui
- Qt::StateMachine
- Qt::Widgets
-)
-
-# Resources:
-set(stickman_resource_files
- "animations/chilling.bin"
- "animations/dancing.bin"
- "animations/dead.bin"
- "animations/jumping.bin"
-)
-
-qt6_add_resources(stickman "stickman"
- PREFIX
- "/"
- FILES
- ${stickman_resource_files}
-)
-
-install(TARGETS stickman
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)