summaryrefslogtreecommitdiffstats
path: root/examples/widgets/animation/moveblocks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/animation/moveblocks/CMakeLists.txt')
-rw-r--r--examples/widgets/animation/moveblocks/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/examples/widgets/animation/moveblocks/CMakeLists.txt b/examples/widgets/animation/moveblocks/CMakeLists.txt
index d531f9f..0a23e50 100644
--- a/examples/widgets/animation/moveblocks/CMakeLists.txt
+++ b/examples/widgets/animation/moveblocks/CMakeLists.txt
@@ -17,16 +17,21 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/animation/moveblocks")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS StateMachine)
find_package(Qt6 COMPONENTS Widgets)
-add_qt_gui_executable(moveblocks
+qt_add_executable(moveblocks
main.cpp
)
+set_target_properties(moveblocks PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(moveblocks PUBLIC
Qt::Core
Qt::Gui
+ Qt::StateMachine
Qt::Widgets
- statemachine
)
install(TARGETS moveblocks