summaryrefslogtreecommitdiffstats
path: root/tests/auto/scion/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/scion/CMakeLists.txt')
-rw-r--r--tests/auto/scion/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/tests/auto/scion/CMakeLists.txt b/tests/auto/scion/CMakeLists.txt
index 9f7020a..9dd6db2 100644
--- a/tests/auto/scion/CMakeLists.txt
+++ b/tests/auto/scion/CMakeLists.txt
@@ -79,8 +79,8 @@ set(scxmls_dir ../../3rdparty/scion-tests/scxml-test-framework/test)
get_filename_component(scxmls_dir ${scxmls_dir} ABSOLUTE)
file(GLOB_RECURSE allscxmls ${scxmls_dir}/*.scxml)
-_qt_internal_wrap_tool_command(qscxmlc_command SET
- "$<TARGET_FILE:${QT_CMAKE_EXPORT_NAMESPACE}::qscxmlc>")
+_qt_internal_get_tool_wrapper_script_path(tool_wrapper)
+set(qscxmlc_bin "${tool_wrapper}" "$<TARGET_FILE:${QT_CMAKE_EXPORT_NAMESPACE}::qscxmlc>")
set(scxmls)
set(inc_list)
@@ -111,7 +111,8 @@ foreach(f ${allscxmls})
file(TO_NATIVE_PATH ${out_cpp} native_out_cpp)
add_custom_command(
OUTPUT ${out_cpp} ${out_h}
- ${qscxmlc_command} --header ${native_out_h} --impl ${native_out_cpp}
+ COMMAND
+ ${qscxmlc_bin} --header ${native_out_h} --impl ${native_out_cpp}
--namespace ${sn} --classname ${cn} ${f}
DEPENDS ${QT_CMAKE_EXPORT_NAMESPACE}::qscxmlc
VERBATIM