summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@insta.fi>2021-08-09 12:09:21 +0300
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-08-16 10:37:58 +0000
commit5991224e6713eef4a456c408fcf797662fa2a66c (patch)
treee02b6b093cf5d7cf2b404ea47678898dfc500431 /CMakeLists.txt
parentc91828e810b1f0f3fa2c2145bdfeb52d8cfac9d1 (diff)
Disable gestures from QtSensors
The sensor gestures requires some rethinking in order to be of more use for the developers. Therefore we should not yet commit to the old API at least in the first Qt 6 sensors release. This commit disables the gestures by: - Excluding gesture code from compilation - Excluding gesture examples and tests from compilation - Excluding the gesture related documentation - And updating the Qt 6 porting guide Task-number: QTBUG-95747 Task-number: QTBUG-95649 Change-Id: I33c1e010825a88b10fa1f7ad49ad3b5383b470aa Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Lorn Potter <lorn.potter@gmail.com> (cherry picked from commit 1e6f2126f11a62813dd652d3df0edb8bff8dfbf1) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 25cdd756..5fb84e19 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ project(QtSensors
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
- Xml Gui Widgets Quick Qml Svg DBus Multimedia QuickTest
+ Xml Gui Widgets Quick Qml Svg DBus QuickTest
)
qt_build_repo()