summaryrefslogtreecommitdiffstats
path: root/src/plugins/sensorgestures/CMakeLists.txt
diff options
context:
space:
mode:
authorLorn Potter <lorn.potter@gmail.com>2021-01-06 07:30:03 +1000
committerJuha Vuolle <juha.vuolle@insta.fi>2021-04-19 13:29:47 +0300
commit45c8ae3232df8955644697ee88c4321f26bb5cf2 (patch)
tree77edea26c249ce6bb8a921fe67c266d3c95e094a /src/plugins/sensorgestures/CMakeLists.txt
parent5a8aa096dc61336ac95734e8cc61f106e359c865 (diff)
QtSensors initial cmake support
This commit introduces the bare minimum cmake support that should unblock the CI and allow further verification and development on most platforms: macOS, Linux, Win, iOS and Android. Some clarifications: * The support for sensorfw backend is very preliminary and can be enabled later if needed (no Qt6 version of the sensorfw). * The simulator backend is dropped as obsolete / unnecessary. * Three examples are currently commented out and shall be ported with a later commit. Task-number: QTBUG-92502 Change-Id: Id523d43ed3ef177010dc73afc5812ed374cff0dd Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/sensorgestures/CMakeLists.txt')
-rw-r--r--src/plugins/sensorgestures/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/plugins/sensorgestures/CMakeLists.txt b/src/plugins/sensorgestures/CMakeLists.txt
new file mode 100644
index 00000000..07fbacc9
--- /dev/null
+++ b/src/plugins/sensorgestures/CMakeLists.txt
@@ -0,0 +1,2 @@
+add_subdirectory(shake)
+add_subdirectory(qtsensors)