summaryrefslogtreecommitdiffstats
path: root/tests/auto/qsensorgestures/plugins/test1/CMakeLists.txt
diff options
context:
space:
mode:
authorLorn Potter <lorn.potter@gmail.com>2021-01-06 07:30:03 +1000
committerJuha Vuolle <juha.vuolle@insta.fi>2021-04-19 13:29:47 +0300
commit45c8ae3232df8955644697ee88c4321f26bb5cf2 (patch)
tree77edea26c249ce6bb8a921fe67c266d3c95e094a /tests/auto/qsensorgestures/plugins/test1/CMakeLists.txt
parent5a8aa096dc61336ac95734e8cc61f106e359c865 (diff)
QtSensors initial cmake support
This commit introduces the bare minimum cmake support that should unblock the CI and allow further verification and development on most platforms: macOS, Linux, Win, iOS and Android. Some clarifications: * The support for sensorfw backend is very preliminary and can be enabled later if needed (no Qt6 version of the sensorfw). * The simulator backend is dropped as obsolete / unnecessary. * Three examples are currently commented out and shall be ported with a later commit. Task-number: QTBUG-92502 Change-Id: Id523d43ed3ef177010dc73afc5812ed374cff0dd Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/qsensorgestures/plugins/test1/CMakeLists.txt')
-rw-r--r--tests/auto/qsensorgestures/plugins/test1/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/qsensorgestures/plugins/test1/CMakeLists.txt b/tests/auto/qsensorgestures/plugins/test1/CMakeLists.txt
new file mode 100644
index 00000000..8a9bc73c
--- /dev/null
+++ b/tests/auto/qsensorgestures/plugins/test1/CMakeLists.txt
@@ -0,0 +1,21 @@
+#####################################################################
+## QTestSensorGestureDupPlugin Plugin:
+#####################################################################
+
+qt_internal_add_plugin(QTestSensorGestureDupPlugin
+ OUTPUT_NAME qtsensorgestures_testplugin1
+ TYPE sensorgestures
+ DEFAULT_IF FALSE
+ SOURCES
+ qtest2recognizerduo.cpp
+ qtest2recognizerdup.h
+ qtestrecognizerdup.cpp qtestrecognizerdup.h
+ qtestsensorgestureplugindup.cpp qtestsensorgestureplugindup_p.h
+ DEFINES
+ QT_DISABLE_DEPRECATED_BEFORE=0
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Sensors
+ Qt::SensorGestures
+)