summaryrefslogtreecommitdiffstats
path: root/tests/manual/sensor_explorer_widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@qt.io>2023-02-17 13:40:13 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-02-24 07:02:17 +0000
commit5fe88f0a260e2fed11ad03702ee3c05f841e7ea8 (patch)
tree03c44feee67c65d7649dfaa2136ad8997d614df3 /tests/manual/sensor_explorer_widgets/CMakeLists.txt
parent2076a336ff3a9f4fa9e6a2d9714f72d31030561b (diff)
Move sensor_explorer QML example to manual tests
The example is useful as a sensor testing tool, but less necessary as an example. The primary demonstrative element of the example was how to iterate the available sensors, which is covered in a documentation snippet (followup commit). This commit also renames the pre-existing widget-based sensor_explorer manual test to avoid name conflicts, as well as removes the qdoc and qmake support from the now-a-manual-test application. Task-number: QTBUG-110939 Change-Id: I422f62f852d0a7e40a76f555ec8aa98404164f7a Reviewed-by: Lorn Potter <lorn.potter@gmail.com> (cherry picked from commit f5426ddda0c8e022d55290de70f96cb4db1801bb) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'tests/manual/sensor_explorer_widgets/CMakeLists.txt')
-rw-r--r--tests/manual/sensor_explorer_widgets/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/manual/sensor_explorer_widgets/CMakeLists.txt b/tests/manual/sensor_explorer_widgets/CMakeLists.txt
new file mode 100644
index 00000000..357eb02e
--- /dev/null
+++ b/tests/manual/sensor_explorer_widgets/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## sensor_explorer Binary:
+#####################################################################
+
+qt_internal_add_manual_test(tst_manual_sensor_explorer_widgets
+ GUI
+ SOURCES
+ explorer.cpp explorer.h explorer.ui
+ main.cpp
+ LIBRARIES
+ Qt::Sensors
+ Qt::Widgets
+ ENABLE_AUTOGEN_TOOLS
+ uic
+)