summaryrefslogtreecommitdiffstats
path: root/examples/sensors/accelbubble/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sensors/accelbubble/CMakeLists.txt')
-rw-r--r--examples/sensors/accelbubble/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/examples/sensors/accelbubble/CMakeLists.txt b/examples/sensors/accelbubble/CMakeLists.txt
new file mode 100644
index 00000000..8d752931
--- /dev/null
+++ b/examples/sensors/accelbubble/CMakeLists.txt
@@ -0,0 +1,52 @@
+cmake_minimum_required(VERSION 3.14)
+project(accelbubble LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/sensors/accelbubble")
+
+find_package(Qt6 COMPONENTS Core Gui Quick Sensors Svg Xml)
+
+qt_add_executable(accelbubble
+ main.cpp
+)
+set_target_properties(accelbubble PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(accelbubble PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Quick
+ Qt::Sensors
+ Qt::Svg
+ Qt::Xml
+)
+
+
+# Resources:
+set(accelbubble_resource_files
+ "accelbubble.qml"
+ "content/Bluebubble.svg"
+)
+
+qt6_add_resources(accelbubble "accelbubble"
+ PREFIX
+ "/"
+ FILES
+ ${accelbubble_resource_files}
+)
+
+install(TARGETS accelbubble
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)