summaryrefslogtreecommitdiffstats
path: root/examples/sensors/grue/console_app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sensors/grue/console_app/CMakeLists.txt')
-rw-r--r--examples/sensors/grue/console_app/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/examples/sensors/grue/console_app/CMakeLists.txt b/examples/sensors/grue/console_app/CMakeLists.txt
new file mode 100644
index 00000000..e6364e48
--- /dev/null
+++ b/examples/sensors/grue/console_app/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Generated from console_app.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(detect_grue LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/sensors/grue")
+
+find_package(Qt6 COMPONENTS Core Sensors)
+
+qt_add_executable(detect_grue
+ main.cpp
+)
+set_target_properties(detect_grue PROPERTIES
+ WIN32_EXECUTABLE FALSE
+ MACOSX_BUNDLE FALSE
+)
+target_link_libraries(detect_grue PUBLIC
+ Qt::Core
+ Qt::Sensors
+)
+
+install(TARGETS detect_grue
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)