summaryrefslogtreecommitdiffstats
path: root/examples/serialbus/can/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeny Shtanov <shtanov_evgenii@mail.ru>2021-03-10 22:33:56 +0300
committerEvgeny Shtanov <shtanov_evgenii@mail.ru>2021-03-19 00:48:34 +0300
commita72f9e33dc8fe60ef80eee0ecf97965fc8482fe9 (patch)
tree6af3cd4cbdfdef1a137bb690f076bb15608eb414 /examples/serialbus/can/CMakeLists.txt
parent55f97fd0178485bafed1e97eaf0d4ebf91a312b5 (diff)
CAN example: Replace received frames edit with proper table and model
Add a class based on QAbstractTableModel to show the received frames. Also add a configurable queue to buffer the frames before displaying them. This should avoid frames loss in flood traffic mode. Task-number: QTBUG-85611 Change-Id: Iac4671096c1cbfdc8297acf3c99be960b7eaf010 Reviewed-by: André Hartmann <aha_1980@gmx.de>
Diffstat (limited to 'examples/serialbus/can/CMakeLists.txt')
-rw-r--r--examples/serialbus/can/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/examples/serialbus/can/CMakeLists.txt b/examples/serialbus/can/CMakeLists.txt
index 0f24732..c9d3a11 100644
--- a/examples/serialbus/can/CMakeLists.txt
+++ b/examples/serialbus/can/CMakeLists.txt
@@ -24,6 +24,8 @@ qt_add_executable(can
main.cpp
mainwindow.cpp mainwindow.h mainwindow.ui
sendframebox.cpp sendframebox.h sendframebox.ui
+ receivedframesmodel.cpp receivedframesmodel.h
+ receivedframesview.cpp receivedframesview.h
)
set_target_properties(can PROPERTIES
WIN32_EXECUTABLE TRUE