summaryrefslogtreecommitdiffstats
path: root/examples/serialbus/modbus/CMakeLists.txt
diff options
context:
space:
mode:
authorKarsten Heimrich <karsten.heimrich@qt.io>2021-03-10 07:54:41 +0100
committerKarsten Heimrich <karsten.heimrich@qt.io>2021-03-10 13:46:15 +0100
commit69ba9acb6a2bbc4c862cd5963cba994a63f2a045 (patch)
tree65ffa9ff9aeabbd98fe35482bc0c05a27de8f55c /examples/serialbus/modbus/CMakeLists.txt
parent94e75b8b0ce02a24bec2b7309615f2638e37a1ce (diff)
Fix Modbus adueditor example depending on private headers
Since our public nor private API can be modified in a way to keep the application working, and, since we need to have such an app to generate invalid and/or illigal frames to test the error handling of the Modbus server, move the example into manual tests. Fixes: QTBUG-55270 Change-Id: I1bc541f19f7327833cc74e9b80065b236969dc3c Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
Diffstat (limited to 'examples/serialbus/modbus/CMakeLists.txt')
-rw-r--r--examples/serialbus/modbus/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/examples/serialbus/modbus/CMakeLists.txt b/examples/serialbus/modbus/CMakeLists.txt
index 6de7ee7..580a311 100644
--- a/examples/serialbus/modbus/CMakeLists.txt
+++ b/examples/serialbus/modbus/CMakeLists.txt
@@ -1,8 +1,3 @@
add_subdirectory(client)
add_subdirectory(server)
add_subdirectory(custom)
-
-if(QT_FEATURE_modbus_serialport)
- add_subdirectory(adueditor)
-endif()
-