summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKarsten Heimrich <karsten.heimrich@qt.io>2021-01-11 15:49:30 +0100
committerKarsten Heimrich <karsten.heimrich@qt.io>2021-01-15 12:34:22 +0100
commit66918b6492297e7750621d85d4372bf45e81a86d (patch)
tree161146a97b8863432ddedb629b700f479189d4c8 /CMakeLists.txt
parentbb26d975c157a70d93e42ddd2748f81440186cf5 (diff)
Qt6: Port module to cmake build system
Fixes: QTBUG-89767 Fixes: QTBUG-89878 Change-Id: I860ae7b9dbb0f79e9e952d594b9737d4c452579a Reviewed-by: Andreas Buhr <andreas.buhr@qt.io> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..1b1c6763
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,36 @@
+cmake_minimum_required(VERSION 3.16)
+
+include(.cmake.conf)
+project(QtSerialPort
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt SerialPort Libraries"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Widgets)
+
+if(INTEGRITY)
+ message(NOTICE "Skipping the build as the condition \"NOT INTEGRITY\" is not met.")
+ return()
+endif()
+if(VXWORKS)
+ message(NOTICE "Skipping the build as the condition \"NOT VXWORKS\" is not met.")
+ return()
+endif()
+if(WINRT)
+ message(NOTICE "Skipping the build as the condition \"NOT WINRT\" is not met.")
+ return()
+endif()
+if(UIKIT)
+ message(NOTICE "Skipping the build as the condition \"NOT UIKIT\" is not met.")
+ return()
+endif()
+if(EMSCRIPTEN)
+ message(NOTICE "Skipping the build as the condition \"NOT EMSCRIPTEN\" is not met.")
+ return()
+endif()
+qt_build_repo()