summaryrefslogtreecommitdiffstats
path: root/tests/manual/examples/sender/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2023-02-08 10:58:10 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-02-10 11:57:29 +0000
commit6ff43af117284bee42c52f8104a5cb93c873690f (patch)
tree82dbc1d462ebd0068706288d2c1312c3025612a1 /tests/manual/examples/sender/CMakeLists.txt
parent6488ca4cfef43bd2b381e2e39ef4b94fe339bad2 (diff)
Move Senred and Receiver examples to manual tests
These examples have no description, so they are not visible in the docs and in QtCreator anyway. The APIs that are shown by these examples are also covered by other examples. Still they can be useful while debugging, so move them to tests/manual/examples. Task-number: QTBUG-110645 Task-number: QTBUG-108868 Change-Id: I7d575372a4b0af57f4564b18f6d024347e812c7e Reviewed-by: Alex Blasche <alexander.blasche@qt.io> (cherry picked from commit b114f04ed2b900884a4df5bc2ce855addbd467c9) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'tests/manual/examples/sender/CMakeLists.txt')
-rw-r--r--tests/manual/examples/sender/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/manual/examples/sender/CMakeLists.txt b/tests/manual/examples/sender/CMakeLists.txt
new file mode 100644
index 00000000..efbd5551
--- /dev/null
+++ b/tests/manual/examples/sender/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(sender LANGUAGES CXX)
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/serialport/sender")
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui SerialPort Widgets)
+
+qt_standard_project_setup()
+
+qt_add_executable(sender
+ dialog.cpp dialog.h
+ main.cpp
+)
+
+set_target_properties(sender PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(sender PRIVATE
+ Qt::Core
+ Qt::Gui
+ Qt::SerialPort
+ Qt::Widgets
+)