summaryrefslogtreecommitdiffstats
path: root/examples/serialport/blockingsender/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/serialport/blockingsender/CMakeLists.txt')
-rw-r--r--examples/serialport/blockingsender/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/serialport/blockingsender/CMakeLists.txt b/examples/serialport/blockingsender/CMakeLists.txt
index 265a728f..d982aa4d 100644
--- a/examples/serialport/blockingsender/CMakeLists.txt
+++ b/examples/serialport/blockingsender/CMakeLists.txt
@@ -4,8 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(blockingsender LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,6 +12,8 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/serialport/blockingsender")
find_package(Qt6 REQUIRED COMPONENTS Core Gui SerialPort Widgets)
+qt_standard_project_setup()
+
qt_add_executable(blockingsender
dialog.cpp dialog.h
main.cpp