summaryrefslogtreecommitdiffstats
path: root/examples/speech/hello_speak/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederik Gladhorn <frederik.gladhorn@qt.io>2019-09-17 10:27:32 +0200
committerJarkko Koivikko <jarkko.koivikko@code-q.fi>2022-02-11 15:39:43 +0200
commitb4dbc0de5b72442ebc982eb6f5e796afad027b62 (patch)
treee6b19b34c481f93bc429826a27de99f93d3f0e4b /examples/speech/hello_speak/CMakeLists.txt
parentf153303d1577dbf334101359f9978249b5445fa4 (diff)
Re-generate the CMake project files
Change-Id: I85d3f7aeae6fe3971eec5b7d2da4e975c09b124c Reviewed-by: Jarkko Koivikko <jarkko.koivikko@code-q.fi>
Diffstat (limited to 'examples/speech/hello_speak/CMakeLists.txt')
-rw-r--r--examples/speech/hello_speak/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/examples/speech/hello_speak/CMakeLists.txt b/examples/speech/hello_speak/CMakeLists.txt
new file mode 100644
index 0000000..4cadc76
--- /dev/null
+++ b/examples/speech/hello_speak/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Generated from hello_speak.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(hello_speak LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/speech/hello_speak")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS TextToSpeech)
+
+qt_add_executable(hello_speak
+ main.cpp
+ mainwindow.cpp mainwindow.h mainwindow.ui
+)
+set_target_properties(hello_speak PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(hello_speak PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::TextToSpeech
+ Qt::Widgets
+)
+
+install(TARGETS hello_speak
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)