summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2020-10-23 15:17:35 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-10-27 11:57:13 +0200
commit29c03c32804df3f9963774013998d969e6f4ae5b (patch)
tree4bfb5a357816a8846e09f131ecb2a7cc23c5c05f /CMakeLists.txt
parent994899d34edcaaf3bd93aa8628532903a6d141b9 (diff)
CMake: Add deferred dependencies to doc tools
qt_internal_add_docs defers dependencies to qdoc, qtattributionsscanner and qhelpgenerator. Call qt_internal_add_deferred_dependencies after those targets have been created. This makes it possible to build the doc tools automatically when building generate_docs_Foo targets without installing first. Change-Id: I4fa5082830303cfb22ed2b590e0e9036c3678cd4 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 85c57dcf1..be0ba4ab1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,3 +32,9 @@ find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
qt_build_repo()
+# special case begin
+
+# Add tool dependencies that were deferred by qt_internal_add_docs.
+qt_internal_add_deferred_dependencies()
+
+# special case end