summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-20 15:46:22 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-20 16:21:45 +0100
commit38bcee54bdf28b00a96c38399ef1f518e7b75231 (patch)
treed357617200f87cf724bcca86fece1e111a6eff50 /CMakeLists.txt
parent9e5e4804e0db1696980ecaf2bd912136ee23fc6f (diff)
CMake: Fix qttools build if qtdeclarative is not available
OpenGL and OpenGLWidgets were implicitly found via qtdeclarative modules, but the configuration fails in case if those are not present. So they should be explicitly searched for. Change-Id: Ia54451f66ca291fac84eb1ba8937d532a5675b8a Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3fa152d71..757abece1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ project(QtTools # special case
# special case begin
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets QmlDevTools Sql PrintSupport)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets QmlDevTools Sql PrintSupport OpenGL OpenGLWidgets)
# special case end
qt_build_repo()