summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-10-15 16:49:00 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-10-15 15:06:10 +0000
commitbd94ebbc85cc42564a618eed2e5fb7bcac8753aa (patch)
treef4f49d255a9323656bed8fd8b7001b681e348070 /CMakeLists.txt
parent342f402c002f1bfcc842dd7711b040de4e2b27e7 (diff)
Regenerate before merge
Change-Id: I857f2c966240b5e056e30531b4bc3e2fc9c68e8e Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e3dc6af2..65f584507 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,12 +1,16 @@
+# Generated from qttools.pro.
+
cmake_minimum_required(VERSION 3.15.0)
-project(QtTools
+project(QtTools # special case
VERSION 6.0.0
- DESCRIPTION "Qt Tools"
+ DESCRIPTION "Qt Tools" # special case
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core
- OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Xml Widgets Quick QuickWidgets) # special case
+
qt_build_repo()
+