summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-19 15:33:46 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-05-25 13:29:45 +0200
commitd6c98c9afcdabc0a427cfb5e885f5f900c572be7 (patch)
tree9676d8e00e315390d74d68a875b7c2cfa16f57c3 /CMakeLists.txt
parente8ebf4f0be2349d80c86ca04bfca0bef5cb8c07b (diff)
Use fixed qt_add_resource BASE argument
Pick-to: 6.1 Task-number: QTBUG-86726 Change-Id: Ibea15ff714958ad3e70a8b86ae8c6c18c94ccf16 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b763d244..aac132d27 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,9 @@ set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+# Make sure we use the fixed BASE argument of qt_add_resource.
+set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
+
# add platform specific compontents
set(optional_components "")
if(WIN32)