summaryrefslogtreecommitdiffstats
path: root/examples/designer/taskmenuextension/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2020-06-03 10:33:28 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2020-06-03 17:37:58 +0200
commit88f4498759de2c3be53933e85ea405ee3554e8b8 (patch)
treef49d2888027f11252631ca04bb0c677eec283092 /examples/designer/taskmenuextension/CMakeLists.txt
parent0666b552bfc145b2a880ca83a1a72a8dfdce477e (diff)
Port QtTools examples to cmake
Change-Id: I11146959edbec6b4577fdd339d0fcb807f53c95b Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/designer/taskmenuextension/CMakeLists.txt')
-rw-r--r--examples/designer/taskmenuextension/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/examples/designer/taskmenuextension/CMakeLists.txt b/examples/designer/taskmenuextension/CMakeLists.txt
new file mode 100644
index 000000000..2ed6c4feb
--- /dev/null
+++ b/examples/designer/taskmenuextension/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Generated from taskmenuextension.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(taskmenuextension LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "plugins/designer") # special case
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS Designer)
+
+# special case begin
+qt_add_plugin(taskmenuextension)
+target_sources(taskmenuextension PRIVATE
+ tictactoe.cpp tictactoe.h
+ tictactoedialog.cpp tictactoedialog.h
+ tictactoeplugin.cpp tictactoeplugin.h
+ tictactoetaskmenu.cpp tictactoetaskmenu.h
+)
+# special case end
+target_link_libraries(taskmenuextension PUBLIC
+ Qt::Core
+ Qt::Designer
+ Qt::Gui
+ Qt::Widgets
+)
+
+install(TARGETS taskmenuextension
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)