summaryrefslogtreecommitdiffstats
path: root/examples/help/contextsensitivehelp/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2020-06-03 10:33:28 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2020-06-03 17:37:58 +0200
commit88f4498759de2c3be53933e85ea405ee3554e8b8 (patch)
treef49d2888027f11252631ca04bb0c677eec283092 /examples/help/contextsensitivehelp/CMakeLists.txt
parent0666b552bfc145b2a880ca83a1a72a8dfdce477e (diff)
Port QtTools examples to cmake
Change-Id: I11146959edbec6b4577fdd339d0fcb807f53c95b Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/help/contextsensitivehelp/CMakeLists.txt')
-rw-r--r--examples/help/contextsensitivehelp/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/examples/help/contextsensitivehelp/CMakeLists.txt b/examples/help/contextsensitivehelp/CMakeLists.txt
new file mode 100644
index 000000000..0bcf89871
--- /dev/null
+++ b/examples/help/contextsensitivehelp/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Generated from contextsensitivehelp.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(contextsensitivehelp LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/help/contextsensitivehelp")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Help)
+find_package(Qt6 COMPONENTS Widgets)
+
+add_qt_gui_executable(contextsensitivehelp
+ helpbrowser.cpp helpbrowser.h
+ main.cpp
+ wateringconfigdialog.cpp wateringconfigdialog.h wateringconfigdialog.ui
+)
+target_link_libraries(contextsensitivehelp PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Help
+ Qt::Widgets
+)
+
+install(TARGETS contextsensitivehelp
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)