summaryrefslogtreecommitdiffstats
path: root/examples/assistant/simpletextviewer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/assistant/simpletextviewer/CMakeLists.txt')
-rw-r--r--examples/assistant/simpletextviewer/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/examples/assistant/simpletextviewer/CMakeLists.txt b/examples/assistant/simpletextviewer/CMakeLists.txt
new file mode 100644
index 000000000..481d12a98
--- /dev/null
+++ b/examples/assistant/simpletextviewer/CMakeLists.txt
@@ -0,0 +1,43 @@
+# Generated from simpletextviewer.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(simpletextviewer LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/assistant/simpletextviewer")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+
+add_qt_gui_executable(simpletextviewer
+ assistant.cpp assistant.h
+ findfiledialog.cpp findfiledialog.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ textedit.cpp textedit.h
+)
+target_compile_definitions(simpletextviewer PUBLIC
+ SRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" # special case
+)
+
+target_link_libraries(simpletextviewer PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+)
+
+install(TARGETS simpletextviewer
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)