summaryrefslogtreecommitdiffstats
path: root/examples/designer/customwidgetplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/designer/customwidgetplugin/CMakeLists.txt')
-rw-r--r--examples/designer/customwidgetplugin/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/examples/designer/customwidgetplugin/CMakeLists.txt b/examples/designer/customwidgetplugin/CMakeLists.txt
new file mode 100644
index 000000000..c9232a2c0
--- /dev/null
+++ b/examples/designer/customwidgetplugin/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Generated from customwidgetplugin.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(customwidgetplugin LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "plugins/designer") # special case
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS UiPlugin)
+
+# special case begin
+qt_add_plugin(customwidgetplugin)
+target_sources(customwidgetplugin PRIVATE
+ analogclock.cpp analogclock.h
+ customwidgetplugin.cpp customwidgetplugin.h
+)
+# special case end
+target_link_libraries(customwidgetplugin PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::UiPlugin
+ Qt::Widgets
+)
+
+install(TARGETS customwidgetplugin
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)