summaryrefslogtreecommitdiffstats
path: root/examples/designer/taskmenuextension/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/designer/taskmenuextension/CMakeLists.txt')
-rw-r--r--examples/designer/taskmenuextension/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/examples/designer/taskmenuextension/CMakeLists.txt b/examples/designer/taskmenuextension/CMakeLists.txt
new file mode 100644
index 000000000..2ed6c4feb
--- /dev/null
+++ b/examples/designer/taskmenuextension/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Generated from taskmenuextension.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(taskmenuextension LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "plugins/designer") # special case
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS Designer)
+
+# special case begin
+qt_add_plugin(taskmenuextension)
+target_sources(taskmenuextension PRIVATE
+ tictactoe.cpp tictactoe.h
+ tictactoedialog.cpp tictactoedialog.h
+ tictactoeplugin.cpp tictactoeplugin.h
+ tictactoetaskmenu.cpp tictactoetaskmenu.h
+)
+# special case end
+target_link_libraries(taskmenuextension PUBLIC
+ Qt::Core
+ Qt::Designer
+ Qt::Gui
+ Qt::Widgets
+)
+
+install(TARGETS taskmenuextension
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)