summaryrefslogtreecommitdiffstats
path: root/examples/designer/worldtimeclockbuilder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/designer/worldtimeclockbuilder/CMakeLists.txt')
-rw-r--r--examples/designer/worldtimeclockbuilder/CMakeLists.txt13
1 files changed, 4 insertions, 9 deletions
diff --git a/examples/designer/worldtimeclockbuilder/CMakeLists.txt b/examples/designer/worldtimeclockbuilder/CMakeLists.txt
index b435dba0d..cbacb3a9e 100644
--- a/examples/designer/worldtimeclockbuilder/CMakeLists.txt
+++ b/examples/designer/worldtimeclockbuilder/CMakeLists.txt
@@ -1,32 +1,28 @@
-# Generated from worldtimeclockbuilder.pro.
-
cmake_minimum_required(VERSION 3.16)
project(worldtimeclockbuilder LANGUAGES CXX)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/designer/worldtimeclockbuilder")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS UiTools)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui UiTools Widgets)
qt_add_executable(worldtimeclockbuilder
main.cpp
)
+
set_target_properties(worldtimeclockbuilder PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(worldtimeclockbuilder PUBLIC
Qt::Core
Qt::Gui
@@ -34,7 +30,6 @@ target_link_libraries(worldtimeclockbuilder PUBLIC
Qt::Widgets
)
-
# Resources:
set(worldtimeclockbuilder_resource_files
"form.ui"